summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Keadle <mkeadle@gentoo.org>2002-12-07 01:34:37 +0000
committerMatt Keadle <mkeadle@gentoo.org>2002-12-07 01:34:37 +0000
commit8bf41a32848ac93bfa740b6cc26c0598ad95baa0 (patch)
treebb2958f745358bce59fa0b090d7cb47a9421c4da /x11-wm/fluxbox/files
parentUpdates to deal with Xft2 (diff)
downloadhistorical-8bf41a32848ac93bfa740b6cc26c0598ad95baa0.tar.gz
historical-8bf41a32848ac93bfa740b6cc26c0598ad95baa0.tar.bz2
historical-8bf41a32848ac93bfa740b6cc26c0598ad95baa0.zip
Whoops. Almost forgot the patch.
Diffstat (limited to 'x11-wm/fluxbox/files')
-rw-r--r--x11-wm/fluxbox/files/fluxbox-0.1.13-Xft2.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-wm/fluxbox/files/fluxbox-0.1.13-Xft2.patch b/x11-wm/fluxbox/files/fluxbox-0.1.13-Xft2.patch
new file mode 100644
index 000000000000..ab24a44fd3d4
--- /dev/null
+++ b/x11-wm/fluxbox/files/fluxbox-0.1.13-Xft2.patch
@@ -0,0 +1,49 @@
+--- configure.in.orig 2002-11-18 11:59:23.000000000 +0100
++++ configure.in 2002-11-20 01:43:36.000000000 +0100
+@@ -235,35 +235,35 @@
+ )
+ AM_CONDITIONAL(GNOME, test x$GNOME = xtrue)
+
+-AC_MSG_CHECKING([whether to have Xft support])
++AC_MSG_CHECKING([whether to have Xft2 support])
+ AC_ARG_ENABLE(
+ xft,
+-[ --enable-xft Xft (antialias) support [default=yes]],
++[ --enable-xft Xft2 (antialias) support [default=yes]],
+ if test x$enableval = "xyes"; then
+- AC_CHECK_LIB(Xft, XftFontOpen,
+- LIBS="$LIBS -lXft"
++ AC_CHECK_LIB(Xft2, XftFontOpen,
++ LIBS="$LIBS -lXft2"
+ XFT=true
+ AC_DEFINE(USE_XFT, 1, "antialias support"),
+ AC_MSG_RESULT([no])
+ XFT=false
+ )
+- AC_CHECK_LIB(Xft, XftDrawStringUtf8,
+- LIBS="$LIBS -lXft"
+- AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft UTF8 support"),
++ AC_CHECK_LIB(Xft2, XftDrawStringUtf8,
++ LIBS="$LIBS -lXft2"
++ AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft2 UTF8 support"),
+ )
+ else
+ AC_MSG_RESULT([no])
+ XFT=false
+ fi,
+- AC_CHECK_LIB(Xft, XftFontOpen,
+- LIBS="$LIBS -lXft"
++ AC_CHECK_LIB(Xft2, XftFontOpen,
++ LIBS="$LIBS -lXft2"
+ XFT=true
+ AC_DEFINE(USE_XFT, 1, "antialias support"),
+ AC_MSG_RESULT([no])
+ XFT=false
+ )
+- AC_CHECK_LIB(Xft, XftDrawStringUtf8,
+- LIBS="$LIBS -lXft"
++ AC_CHECK_LIB(Xft2, XftDrawStringUtf8,
++ LIBS="$LIBS -lXft2"
+ AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft UTF8 support"),
+ )
+ )