summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2002-02-20 04:36:33 +0000
committerChris Houser <chouser@gentoo.org>2002-02-20 04:36:33 +0000
commit8b452c62a0ffb80e81bca64340650bda6f125e1c (patch)
treea70f9a48b84393cd00eec86e7b047837691b8b1c /x11-wm/icewm
parentusing make vs emake now (diff)
downloadhistorical-8b452c62a0ffb80e81bca64340650bda6f125e1c.tar.gz
historical-8b452c62a0ffb80e81bca64340650bda6f125e1c.tar.bz2
historical-8b452c62a0ffb80e81bca64340650bda6f125e1c.zip
Added support for 'nls' and 'imlib' in USE. This closes bug #521. Moved some
install paths out of X11 sub-directories into FHS-compliant locations. Switched to using dohtml instead of dodoc and patched source so that the 'help' menu item now works.
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/ChangeLog8
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.0.9.2-r31
-rw-r--r--x11-wm/icewm/icewm-1.0.9.2-r3.ebuild56
3 files changed, 64 insertions, 1 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index 496b61a92fba..2ac19e94c88f 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/icewm
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.3 2002/02/14 22:12:39 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.4 2002/02/20 04:36:33 chouser Exp $
+
+*icewm-1.0.9.2-r3 (19 Feb 2002)
+
+ 19 Feb 2002; Chris Houser <chouser@gentoo.org>: added support for 'nls' and
+ 'imlib' in USE. Moved some install paths out of X11 sub-directories into
+ FHS-compliant locations. Fixed the 'help' menu item. This closes bug #521.
*icewm-1.0.9.2-r2 (14 Feb 2002)
diff --git a/x11-wm/icewm/files/digest-icewm-1.0.9.2-r3 b/x11-wm/icewm/files/digest-icewm-1.0.9.2-r3
new file mode 100644
index 000000000000..14ee41d7fddd
--- /dev/null
+++ b/x11-wm/icewm/files/digest-icewm-1.0.9.2-r3
@@ -0,0 +1 @@
+MD5 076d02415b694518b61b569ddd12822c icewm-1.0.9-2.tar.gz 630017
diff --git a/x11-wm/icewm/icewm-1.0.9.2-r3.ebuild b/x11-wm/icewm/icewm-1.0.9.2-r3.ebuild
new file mode 100644
index 000000000000..131aca9a533a
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.0.9.2-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/sys-apps/mosix-user/mosix-user-1.5.2.ebuild,v 1.4 2001/11/25 02:40:12 drobbins Exp
+
+NV=1.0.9-2
+S=${WORKDIR}/icewm-1.0.9
+DESCRIPTION="Ice Window Manager"
+SRC_URI="prdownloads.sourceforge.net/${PN}/${PN}-${NV}.tar.gz"
+HOMEPAGE="www.icewm.org"
+
+DEPEND="virtual/x11
+ nls? ( >=sys-devel/gettext-0.10.40 )
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )"
+
+src_unpack(){
+ unpack ${A}
+ cd ${S}
+
+ # icewm's doc dir layout is un-gentoo-like. To fix it, we have
+ # "make install" skip the docs install, and do it ourselves. That also
+ # means we have to adjust the Makefile so that it can find the help files
+ # when you choose the 'help' item out of its menu.
+ t=src/Makefile
+ cp $t $t.orig
+ sed 's:icewm-$(VERSION)/::' $t.orig > $t
+}
+
+src_compile(){
+ use nls && myconf="$myconf --enable-nls" \
+ || myconf="$myconf --disable-nls"
+ use imlib && myconf="$myconf --with-imlib" \
+ || myconf="$myconf --without-imlib"
+ ./configure \
+ --build=${CHOST} \
+ --prefix=/usr \
+ --with-libdir=/usr/lib/icewm \
+ --with-cfgdir=/etc/icewm \
+ --with-docdir=/usr/share/doc/${PF}/html \
+ $myconf || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install(){
+ make \
+ prefix=${D}/usr \
+ LIBDIR=${D}/usr/lib/icewm \
+ CFGDIR=${D}/etc/icewm \
+ DOCDIR=${S}/dummy \
+ install || die "make install failed"
+ dodoc AUTHORS BUGS CHANGES COPYING FAQ PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/icewm
+}