summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-03-17 21:44:48 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-03-17 21:44:48 +0000
commit97531b0956ca592cdc9abe52b8b36ad9f068d7c8 (patch)
treef30ce997d5afc1fca7a3e3448fa19f779bc8f72a /x11-wm/sawfish
parentfix build problem (diff)
downloadhistorical-97531b0956ca592cdc9abe52b8b36ad9f068d7c8.tar.gz
historical-97531b0956ca592cdc9abe52b8b36ad9f068d7c8.tar.bz2
historical-97531b0956ca592cdc9abe52b8b36ad9f068d7c8.zip
fix build problem with latest libtool
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/ChangeLog8
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-1.0.1-r21
-rw-r--r--x11-wm/sawfish/files/sawfish-1.0.1-exec.patch13
-rw-r--r--x11-wm/sawfish/sawfish-1.0.1-r2.ebuild91
-rw-r--r--x11-wm/sawfish/sawfish-1.0.1.ebuild81
5 files changed, 112 insertions, 82 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 2b18d5feab50..9381e74e646b 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/sawfish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.1 2002/02/01 21:53:39 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.2 2002/03/17 21:44:48 azarah Exp $
+
+*sawfish-1.0.1-r2 (16 Mar 2002)
+
+ 16 Mar 2002; M.Schlemmer <azarah@gentoo.org> :
+
+ Fix build errors with libtool-1.4 or later.
*sawfish-1.0.1-r1 (1 Feb 2002)
diff --git a/x11-wm/sawfish/files/digest-sawfish-1.0.1-r2 b/x11-wm/sawfish/files/digest-sawfish-1.0.1-r2
new file mode 100644
index 000000000000..3592e2b26ab4
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-1.0.1-r2
@@ -0,0 +1 @@
+MD5 b1587ea76cca08ec951f2536c17a307e sawfish-1.0.1.tar.gz 1326727
diff --git a/x11-wm/sawfish/files/sawfish-1.0.1-exec.patch b/x11-wm/sawfish/files/sawfish-1.0.1-exec.patch
new file mode 100644
index 000000000000..0033ea08e62f
--- /dev/null
+++ b/x11-wm/sawfish/files/sawfish-1.0.1-exec.patch
@@ -0,0 +1,13 @@
+--- lisp/Makefile.in.orig Sat Mar 16 17:55:30 2002
++++ lisp/Makefile.in Sat Mar 16 17:57:12 2002
+@@ -26,8 +26,7 @@
+ VPATH=@srcdir@:@top_srcdir@
+
+ # also in themes/Makefile.in
+-sawfish_prog = $(rep_LIBTOOL) --mode=execute -dlopen ../src/gradient.la \
+- ../src/sawfish --batch --no-rc
++sawfish_prog = ../src/sawfish --batch --no-rc
+ COMPILE_ENV = SAWFISHLISPDIR=. \
+ SAWFISHEXECDIR=$(top_builddir)/src/.libexec \
+ SAWFISHDOCFILE=../DOC
+
diff --git a/x11-wm/sawfish/sawfish-1.0.1-r2.ebuild b/x11-wm/sawfish/sawfish-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..fee87be95ce1
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.0.1-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.0.1-r2.ebuild,v 1.1 2002/03/17 21:44:48 azarah Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="http://prdownloads.sourceforge.net/sawmill/"${A}
+HOMEPAGE="http://sawmill.sourceforge.net/"
+
+DEPEND=">=dev-libs/rep-gtk-0.15-r1
+ >=dev-libs/librep-0.14
+ >=media-libs/imlib-1.9.10-r1
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1
+ >=gnome-base/gnome-core-1.4.0.4-r1 )"
+
+RDEPEND=">=dev-libs/rep-gtk-0.15-r1
+ >=dev-libs/librep-0.14
+ >=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/imlib-1.9.10-r1
+ esd? ( >=media-sound/esound-0.2.22 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1
+ >=gnome-base/gnome-core-1.4.0.4-r1 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 <${FILESDIR}/capplet-crash.patch || die
+ #fix buggy Makefile with newer libtool
+ patch -p0 <${FILESDIR}/sawfish-${PV}-exec.patch || die
+
+ #update libtool for "relink" bug fix
+ libtoolize --copy --force
+ aclocal
+}
+
+src_compile() {
+
+ local myconf
+ if [ "`use esd`" ]
+ then
+ myconf="--with-esd"
+ else
+ myconf="--without-esd"
+ fi
+ if [ "`use gnome`" ]
+ then
+ myconf="${myconf} --with-gnome-prefix=/usr --enable-gnome-widgets --enable-capplet"
+ else
+ myconf="${myconf} --disable-gnome-widgets --disable-capplet --without-gdk-pixbuf"
+ fi
+ if [ "`use readline`" ]
+ then
+ myconf="${myconf} --with-readline"
+ else
+ myconf="${myconf} --without-readline"
+ fi
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-linguas"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-audiofile \
+ ${myconf} || die
+
+ #pmake doesn't work, stick with make
+ make || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ install || die
+
+ dodoc AUTHORS BUGS COPYING ChangeLog
+ dodoc DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+}
+
diff --git a/x11-wm/sawfish/sawfish-1.0.1.ebuild b/x11-wm/sawfish/sawfish-1.0.1.ebuild
deleted file mode 100644
index 2c9cc52712af..000000000000
--- a/x11-wm/sawfish/sawfish-1.0.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.0.1.ebuild,v 1.1 2001/11/03 02:36:32 azarah Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
-SRC_URI="http://prdownloads.sourceforge.net/sawmill/"${A}
-HOMEPAGE="http://sawmill.sourceforge.net/"
-
-DEPEND=">=dev-libs/rep-gtk-0.15-r1
- >=dev-libs/librep-0.14
- >=media-libs/imlib-1.9.10-r1
- esd? ( >=media-sound/esound-0.2.22 )
- readline? ( >=sys-libs/readline-4.1 )
- nls? ( sys-devel/gettext )
- gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1
- >=gnome-base/gnome-core-1.4.0.4-r1 )"
-
-RDEPEND=">=dev-libs/rep-gtk-0.15-r1
- >=dev-libs/librep-0.14
- >=x11-libs/gtk+-1.2.10-r4
- >=media-libs/imlib-1.9.10-r1
- esd? ( >=media-sound/esound-0.2.22 )
- gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1
- >=gnome-base/gnome-core-1.4.0.4-r1 )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}/po
- cp zh_TW.Big5.po zh_TW.Big5.po.orig
- sed -e "s:\\\::g" zh_TW.Big5.po.orig > zh_TW.Big5.po
- rm zh_TW.Big5.po.orig
-}
-
-src_compile() {
-
- local myconf
- if [ "`use esd`" ]
- then
- myconf="--with-esd"
- else
- myconf="--without-esd"
- fi
- if [ "`use gnome`" ]
- then
- myconf="${myconf} --with-gnome-prefix=/usr --enable-gnome-widgets --enable-capplet"
- else
- myconf="${myconf} --disable-gnome-widgets --disable-capplet --without-gdk-pixbuf"
- fi
- if [ "`use readline`" ]
- then
- myconf="${myconf} --with-readline"
- else
- myconf="${myconf} --without-readline"
- fi
- if [ -z "`use nls`" ]
- then
- myconf="${myconf} --disable-linguas"
- fi
-
- try ./configure --host=${CHOST} --prefix=/usr --infodir=/usr/share/info --libexecdir=/usr/lib --with-audiofile ${myconf}
-
- #pmake doesn't work, stick with make
- try make
-}
-
-src_install() {
-
- try make DESTDIR=${D} install
- dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
-
- # Add to Gnome CC's Window Manager list
- insinto /usr/share/gnome/wm-properties
- doins ${FILESDIR}/Sawfish.desktop
-
-}
-
-
-