summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Conrad Tilstra <tadpol@gentoo.org>2001-08-09 03:38:36 +0000
committerMichael Conrad Tilstra <tadpol@gentoo.org>2001-08-09 03:38:36 +0000
commite7ac33375c31d3cccf17747c90bf10c55ec0a35b (patch)
treef90f870107c62cf546c43da1ba4a0830467e3ee5 /x11-wm
parentsecurity advisory templates... very much still a work in progress... being ch... (diff)
downloadhistorical-e7ac33375c31d3cccf17747c90bf10c55ec0a35b.tar.gz
historical-e7ac33375c31d3cccf17747c90bf10c55ec0a35b.tar.bz2
historical-e7ac33375c31d3cccf17747c90bf10c55ec0a35b.zip
added a check for opengl. Seems strange, but if the fltk libs are built to
use opengl this ebuild fails. So we should check as well. Not that hard, just an extra libaray.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/flwm/files/digest-flwm-1.00-r11
-rw-r--r--x11-wm/flwm/flwm-1.00-r1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-wm/flwm/files/digest-flwm-1.00-r1 b/x11-wm/flwm/files/digest-flwm-1.00-r1
new file mode 100644
index 000000000000..b1e10d23fcae
--- /dev/null
+++ b/x11-wm/flwm/files/digest-flwm-1.00-r1
@@ -0,0 +1 @@
+MD5 75047b2ddcac30eecfb380773177d54d flwm-1.00.tgz
diff --git a/x11-wm/flwm/flwm-1.00-r1.ebuild b/x11-wm/flwm/flwm-1.00-r1.ebuild
new file mode 100644
index 000000000000..be4858b5acef
--- /dev/null
+++ b/x11-wm/flwm/flwm-1.00-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Michael Conrad Tilstra <tadpol@gentoo.org> <tadpol@tadpol.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/flwm/flwm-1.00-r1.ebuild,v 1.1 2001/08/09 03:38:36 tadpol Exp $
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+SRC_URI="http://flwm.sourceforge.net/${A}"
+HOMEPAGE="http://flwm.sourceforge.net"
+DESCRIPTION="A lightweight window manager based on fltk"
+
+DEPEND=">=x11-base/xfree-4.0.1
+ >=x11-libs/fltk-1.0.11
+ opengl? ( virtual/opengl )
+"
+
+src_compile() {
+ if [ "`use opengl`" ]; then
+ export X_EXTRA_LIBS=-lGL
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST}
+ try make
+}
+
+src_install() {
+ doman flwm.1
+ dodoc README flwm_wmconfig
+ into /usr/X11R6
+ dobin flwm
+}