summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-03-26 08:25:47 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-03-26 08:25:47 +0000
commiteb7ac9ff26d6dd8ee69428be0d3fccfabeaa1f52 (patch)
treea65261a760912c9c497e83ffe9d985300acc37c4 /x11-wm
parentSet stable on ppc (diff)
downloadhistorical-eb7ac9ff26d6dd8ee69428be0d3fccfabeaa1f52.tar.gz
historical-eb7ac9ff26d6dd8ee69428be0d3fccfabeaa1f52.tar.bz2
historical-eb7ac9ff26d6dd8ee69428be0d3fccfabeaa1f52.zip
New upstream release, bumped into x86 unstable only.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish/ChangeLog7
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-1.31
-rw-r--r--x11-wm/sawfish/sawfish-1.3.ebuild73
3 files changed, 80 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index b566a8ec39fa..a09b8e07094a 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/sawfish
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.26 2003/02/12 09:52:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.27 2003/03/26 08:25:47 drobbins Exp $
+
+*sawfish-1.3 (25 Mar 2003)
+
+ 25 Mar 2003; Daniel Robbins <drobbins@gentoo.org> sawfish-1.3.ebuild:
+ New upstream release.
05 Feb 2003; Aron Griffis <agriffis@gentoo.org> sawfish-1.2.ebuild :
Mark stable on alpha
diff --git a/x11-wm/sawfish/files/digest-sawfish-1.3 b/x11-wm/sawfish/files/digest-sawfish-1.3
new file mode 100644
index 000000000000..329b7f1c34ed
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-1.3
@@ -0,0 +1 @@
+MD5 9e5ce5e76c60acecdb1889c1f173295a sawfish-1.3.tar.gz 1582279
diff --git a/x11-wm/sawfish/sawfish-1.3.ebuild b/x11-wm/sawfish/sawfish-1.3.ebuild
new file mode 100644
index 000000000000..a8d8187df461
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.3.ebuild,v 1.1 2003/03/26 08:25:47 drobbins Exp $
+
+inherit base eutils
+
+IUSE="readline esd nls"
+
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="mirror://sourceforge/sawmill/${P}.tar.gz"
+HOMEPAGE="http://sawmill.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=x11-libs/rep-gtk-0.17
+ =dev-libs/librep-0.16*
+ >=media-libs/imlib-1.9.10-r1
+ media-libs/audiofile
+ >=x11-libs/gtk+-2.0.8
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )"
+
+
+src_unpack() {
+ base_src_unpack
+}
+
+src_compile() {
+
+ local myconf=""
+ use esd && myconf="${myconf} --with-esd"
+ use esd || myconf="${myconf} --without-esd"
+
+ use readline && myconf="${myconf} --with-readline"
+ use readline || myconf="${myconf} --without-readline"
+
+ use nls || myconf="${myconf} --disable-linguas"
+
+ # Make sure we include freetype2 headers before freetype1 headers, else Xft2
+ # borks,
+ # <azarah@gentoo.org> (13 Dec 2002)
+ export C_INCLUDE_PATH="${C_INCLUDE_PATH}:/usr/include/freetype2"
+ export CPLUS_INCLUDE_PATH="${CPLUS_INCLUDE_PATH}:/usr/include/freetype2"
+
+ # The themer is currently broken (must have rep-gtk-0.15
+ # installed to get it compiled) - Azarah, 24 Jun 2002
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-gnome-prefix=/usr \
+ --enable-gnome-widgets \
+ --enable-capplet \
+ --disable-themer \
+ --with-gdk-pixbuf \
+ --with-audiofile \
+ ${myconf} || die
+
+ # DO NOT USE "emake" !!! - Azarah, 24 Jun 2002
+ MAKEOPTS=-j1 make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+}