summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-22 16:33:34 +0000
committerChristoph Mende <angelos@gentoo.org>2010-05-22 16:33:34 +0000
commitcd2456c51f18a0ad1a74539dc202c4d696d439fd (patch)
treed548525b6d9b96681442f35d299a1469cfed2797 /xfce-base/xfce-utils
parentVersion bump to 1.3.24 and 1.4.6, bug 305261. (diff)
downloadhistorical-cd2456c51f18a0ad1a74539dc202c4d696d439fd.tar.gz
historical-cd2456c51f18a0ad1a74539dc202c4d696d439fd.tar.bz2
historical-cd2456c51f18a0ad1a74539dc202c4d696d439fd.zip
Version bump
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'xfce-base/xfce-utils')
-rw-r--r--xfce-base/xfce-utils/ChangeLog10
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.6.2.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index 3868351b9c31..3d070b7382bb 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce-utils
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.145 2009/10/13 21:09:59 darkside Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.146 2010/05/22 16:30:08 angelos Exp $
+
+*xfce-utils-4.6.2 (22 May 2010)
+
+ 22 May 2010; Christoph Mende <angelos@gentoo.org>
+ +xfce-utils-4.6.2.ebuild:
+ Version bump
13 Oct 2009; Jeremy Olexa <darkside@gentoo.org> xfce-utils-4.6.1.ebuild:
Fix out of prefix error for Gentoo Prefix. No change for Gentoo Linux
diff --git a/xfce-base/xfce-utils/xfce-utils-4.6.2.ebuild b/xfce-base/xfce-utils/xfce-utils-4.6.2.ebuild
new file mode 100644
index 000000000000..32bf1a0e0af5
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.6.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.6.2.ebuild,v 1.1 2010/05/22 16:30:08 angelos Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Collection of utils for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfce-utils/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.6/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dbus debug +lock"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libX11
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/xfconf-4.6
+ dbus? ( >=dev-libs/dbus-glib-0.70 )
+ lock? ( || ( x11-misc/xscreensaver
+ gnome-extra/gnome-screensaver
+ x11-misc/xlockmore ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable dbus)
+ $(use_enable debug)
+ --with-vendor-info=Gentoo
+ --with-xsession-prefix="${EPREFIX}"/usr"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_install() {
+ xfconf_src_install
+ insinto /usr/share/xfce4
+ doins "${FILESDIR}"/Gentoo || die "doins failed"
+ echo startxfce4 > "${T}"/Xfce4
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/Xfce4 || die "doexe failed"
+}
+
+pkg_postinst() {
+ elog "Run Xfce4 from your favourite Display Manager by using"
+ elog "XSESSION=\"Xfce4\" in /etc/rc.conf"
+}