summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-20 02:43:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-20 02:43:37 +0000
commit695570156ef09a5c01a5536fc850f01aeb1ee557 (patch)
tree042a35e9007dea8e9c2229f505261579ea26dc53 /xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.10.ebuild
parentDev channel bump. (diff)
downloadhistorical-695570156ef09a5c01a5536fc850f01aeb1ee557.tar.gz
historical-695570156ef09a5c01a5536fc850f01aeb1ee557.tar.bz2
historical-695570156ef09a5c01a5536fc850f01aeb1ee557.zip
Version bump.
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.10.ebuild')
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.10.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.10.ebuild b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.10.ebuild
new file mode 100644
index 000000000000..6aa877c0f8fd
--- /dev/null
+++ b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.4.10.ebuild,v 1.1 2012/06/20 02:43:37 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="A panel plug-in to control MPRIS2 compatible players like Pragha (from the same authors)"
+HOMEPAGE="https://github.com/matiasdelellis/xfce4-soundmenu-plugin"
+SRC_URI="mirror://github/matiasdelellis/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +glyr lastfm"
+
+RDEPEND=">=dev-libs/dbus-glib-0.98
+ >=dev-libs/keybinder-0.2.2
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8
+ glyr? ( >=media-libs/glyr-0.9.9 )
+ lastfm? ( >=media-libs/libclastfm-0.5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-static
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}