summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/xfsdump/ChangeLog7
-rw-r--r--sys-fs/xfsdump/Manifest19
-rw-r--r--sys-fs/xfsdump/files/xfsdump-2.2.30-docs.patch18
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.30.ebuild7
4 files changed, 40 insertions, 11 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index 086e722fc212..a1b002a3b15c 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,9 +1,10 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.22 2005/09/03 19:16:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.23 2005/09/04 05:16:09 vapier Exp $
- 03 Sep 2005; Robin H. Johnson <robbat2@gentoo.org> xfsdump-2.2.30.ebuild:
- Add symlink for xfsdq, and trying to debug bug #104771.
+ 04 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/xfsdump-2.2.30-docs.patch, xfsdump-2.2.30.ebuild:
+ Touchup doc install and fix sandbox issues #104711.
*xfsdump-2.2.30 (02 Sep 2005)
diff --git a/sys-fs/xfsdump/Manifest b/sys-fs/xfsdump/Manifest
index d7e61ec9cd8e..e71764096a83 100644
--- a/sys-fs/xfsdump/Manifest
+++ b/sys-fs/xfsdump/Manifest
@@ -1,6 +1,17 @@
-MD5 186037a24363b83facbae377556b33c4 xfsdump-2.2.25.ebuild 1174
-MD5 b372c3ca4a6eb190b9a0b54c7da7bbc2 ChangeLog 4799
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 9d471c6ee6bf52e469cfcf5a60c0f8ad xfsdump-2.2.30.ebuild 1182
-MD5 bd977825057d1743222d22dfc80b873c files/digest-xfsdump-2.2.25 70
+MD5 9ebced9335ea25de7a28195193b14f53 xfsdump-2.2.30.ebuild 1135
+MD5 186037a24363b83facbae377556b33c4 xfsdump-2.2.25.ebuild 1174
+MD5 540e35916716b189549b5adef7a4376f ChangeLog 4827
+MD5 e6c3a4b8814bbbc2914e1a7c105d9de0 files/xfsdump-2.2.30-docs.patch 456
MD5 7f8b8584bd4200d9e763433df9f2acb3 files/digest-xfsdump-2.2.30 70
+MD5 bd977825057d1743222d22dfc80b873c files/digest-xfsdump-2.2.25 70
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDGoNEgIKl8Uu19MoRAlo9AJ0frWmh3OftGGP4tV0G6OdUI8OO7gCfXmGd
+Dh9efFtWlaPOWl8E3E6WTiM=
+=pOSP
+-----END PGP SIGNATURE-----
diff --git a/sys-fs/xfsdump/files/xfsdump-2.2.30-docs.patch b/sys-fs/xfsdump/files/xfsdump-2.2.30-docs.patch
new file mode 100644
index 000000000000..5abfc78f346a
--- /dev/null
+++ b/sys-fs/xfsdump/files/xfsdump-2.2.30-docs.patch
@@ -0,0 +1,18 @@
+--- doc/Makefile
++++ doc/Makefile
+@@ -52,13 +52,8 @@
+ CHANGES.gz:
+ $(ZIP) --best -c < CHANGES > $@
+
+-install: default
++install:
+ $(INSTALL) -m 755 -d $(PKG_DOC_DIR)
+- $(INSTALL) -m 644 PORTING CHANGES.gz $(README) $(PKG_DOC_DIR)
+-ifeq ($(PKG_DISTRIBUTION), debian)
+- $(INSTALL) -S CHANGES.gz $(PKG_DOC_DIR)/changelog.gz
+-else
+- $(INSTALL) -m 644 COPYING $(PKG_DOC_DIR)
+-endif
++ $(INSTALL) -m 644 PORTING CHANGES $(README) $(PKG_DOC_DIR)
+
+ install-dev:
diff --git a/sys-fs/xfsdump/xfsdump-2.2.30.ebuild b/sys-fs/xfsdump/xfsdump-2.2.30.ebuild
index 732428c6a47e..83d6ce3434f2 100644
--- a/sys-fs/xfsdump/xfsdump-2.2.30.ebuild
+++ b/sys-fs/xfsdump/xfsdump-2.2.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.30.ebuild,v 1.2 2005/09/03 19:16:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.30.ebuild,v 1.3 2005/09/04 05:16:09 vapier Exp $
inherit eutils
@@ -21,6 +21,7 @@ DEPEND="sys-fs/e2fsprogs
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/xfsdump-2.2.30-docs.patch
sed -i \
-e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
-e '/^GCFLAGS/s:-O1::' \
@@ -46,8 +47,6 @@ src_compile() {
src_install() {
make DIST_ROOT="${D}" install || die
- einfo "Making symlinks"
- dosym /sbin/xfsrestore /usr/bin/xfsrestore
- dosym /sbin/xfsdump /usr/bin/xfsdump
dosym /sbin/xfsdq /usr/bin/xfsdq
+ prepalldocs
}