summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/actionmailer/ChangeLog8
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.0.5.ebuild16
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-2.0.5.ebuild16
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.0.5.ebuild21
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-2.0.5.ebuild16
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.0.5.ebuild48
10 files changed, 150 insertions, 5 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 027bcca36d62..0ae01c10c1f8 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.82 2008/09/13 09:03:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.83 2008/10/20 19:32:07 graaff Exp $
+
+*actionmailer-2.0.5 (20 Oct 2008)
+
+ 20 Oct 2008; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-2.0.5.ebuild:
+ Version bump for Rails 2.0.5
*actionmailer-2.1.1 (13 Sep 2008)
diff --git a/dev-ruby/actionmailer/actionmailer-2.0.5.ebuild b/dev-ruby/actionmailer/actionmailer-2.0.5.ebuild
new file mode 100644
index 000000000000..f9eefd80ff1c
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.0.5.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.0.5.ebuild,v 1.1 2008/10/20 19:32:07 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="=dev-ruby/actionpack-2.0.5
+ >=dev-lang/ruby-1.8.5"
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 179c83979229..6970b159b091 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.83 2008/09/13 09:01:20 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.84 2008/10/20 19:30:24 graaff Exp $
+
+*actionpack-2.0.5 (20 Oct 2008)
+
+ 20 Oct 2008; Hans de Graaff <graaff@gentoo.org> +actionpack-2.0.5.ebuild:
+ Version bump for Rails 2.0.5
*actionpack-2.1.1 (13 Sep 2008)
diff --git a/dev-ruby/actionpack/actionpack-2.0.5.ebuild b/dev-ruby/actionpack/actionpack-2.0.5.ebuild
new file mode 100644
index 000000000000..aeefa95c868a
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-2.0.5.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-2.0.5.ebuild,v 1.1 2008/10/20 19:30:24 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ =dev-ruby/activesupport-2.0.5"
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 25c41e49443d..68b61228ba09 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.81 2008/09/13 09:06:38 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.82 2008/10/20 19:33:47 graaff Exp $
+
+*activerecord-2.0.5 (20 Oct 2008)
+
+ 20 Oct 2008; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.0.5.ebuild:
+ Version bump for Rails 2.0.5
*activerecord-2.1.1 (13 Sep 2008)
diff --git a/dev-ruby/activerecord/activerecord-2.0.5.ebuild b/dev-ruby/activerecord/activerecord-2.0.5.ebuild
new file mode 100644
index 000000000000..a09868e0d9da
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.0.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.0.5.ebuild,v 1.1 2008/10/20 19:33:47 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ =dev-ruby/activesupport-2.0.5
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index b92f8c6e6c8c..483b44712f8e 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.13 2008/09/13 08:59:21 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.14 2008/10/20 19:28:48 graaff Exp $
+
+*activeresource-2.0.5 (20 Oct 2008)
+
+ 20 Oct 2008; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-2.0.5.ebuild:
+ Version bump for Rails 2.0.5
*activeresource-2.1.1 (13 Sep 2008)
diff --git a/dev-ruby/activeresource/activeresource-2.0.5.ebuild b/dev-ruby/activeresource/activeresource-2.0.5.ebuild
new file mode 100644
index 000000000000..eaefa6c2dd19
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-2.0.5.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-2.0.5.ebuild,v 1.1 2008/10/20 19:28:48 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ ~dev-ruby/activesupport-2.0.5"
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index c7dc17b2114d..fd9749b559da 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.112 2008/09/13 09:09:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.113 2008/10/20 19:35:46 graaff Exp $
+
+*rails-2.0.5 (20 Oct 2008)
+
+ 20 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.5.ebuild:
+ Version bump for Rails 2.0.5
*rails-2.1.1 (13 Sep 2008)
diff --git a/dev-ruby/rails/rails-2.0.5.ebuild b/dev-ruby/rails/rails-2.0.5.ebuild
new file mode 100644
index 000000000000..2f72d86208a3
--- /dev/null
+++ b/dev-ruby/rails/rails-2.0.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.0.5.ebuild,v 1.1 2008/10/20 19:35:46 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.5
+ >=app-admin/eselect-rails-0.11
+ >=dev-ruby/rake-0.7.2
+ ~dev-ruby/activerecord-2.0.5
+ ~dev-ruby/activeresource-2.0.5
+ ~dev-ruby/activesupport-2.0.5
+ ~dev-ruby/actionmailer-2.0.5
+ ~dev-ruby/actionpack-2.0.5
+ !<dev-ruby/rails-1.1.6-r1"
+
+RDEPEND="${DEPEND}
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )"
+
+src_install() {
+ gems_src_install
+ # Rename slotted files that may clash so that eselect can handle
+ # them
+ mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
+ mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
+}
+
+pkg_postinst() {
+ einfo "To select between slots of rails, use:"
+ einfo "\teselect rails"
+ # Bring users to rails 2.0.x by default when updating
+ eselect rails update 2
+
+ ewarn "All database USE flags have been moved to dev-ruby/activerecord"
+}
+
+pkg_postrm() {
+ # Drop users back to rails 1.2.x when they remove 2.0.x
+ eselect rails update 1.2
+}