summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/gnustep-back/ChangeLog10
-rw-r--r--dev-util/gnustep-back/files/digest-gnustep-back-0.8.31
-rw-r--r--dev-util/gnustep-back/files/gnustep-back-0.8.3.xft1.patch19
-rw-r--r--dev-util/gnustep-back/gnustep-back-0.8.3.ebuild48
4 files changed, 77 insertions, 1 deletions
diff --git a/dev-util/gnustep-back/ChangeLog b/dev-util/gnustep-back/ChangeLog
index 7ffcd05a27c1..2376e64e9ee4 100644
--- a/dev-util/gnustep-back/ChangeLog
+++ b/dev-util/gnustep-back/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/gnustep-back
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-back/ChangeLog,v 1.4 2002/12/13 10:56:49 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-back/ChangeLog,v 1.5 2003/02/04 19:07:02 raker Exp $
+
+*gnustep-back-0.8.3 (04 Feb 2003)
+
+ 04 Feb 2003; Nick Hadaway <raker@gentoo.org> gnustep-back-0.8.3.ebuild,
+ files/digest-gnustep-back-0.8.3, files/gnustep-back-0.8.3.xft1.patch :
+ Make sure /root/GNUstep doesn't exist before compiling otherwise
+ you'll get lots of warnings. Version bump. Marked unstable.
+
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/dev-util/gnustep-back/files/digest-gnustep-back-0.8.3 b/dev-util/gnustep-back/files/digest-gnustep-back-0.8.3
new file mode 100644
index 000000000000..0c098150598f
--- /dev/null
+++ b/dev-util/gnustep-back/files/digest-gnustep-back-0.8.3
@@ -0,0 +1 @@
+MD5 213ac778852d0b008560b96ef1cd2a79 gnustep-back-0.8.3.tar.gz 319411
diff --git a/dev-util/gnustep-back/files/gnustep-back-0.8.3.xft1.patch b/dev-util/gnustep-back/files/gnustep-back-0.8.3.xft1.patch
new file mode 100644
index 000000000000..ff6f0b5c07a0
--- /dev/null
+++ b/dev-util/gnustep-back/files/gnustep-back-0.8.3.xft1.patch
@@ -0,0 +1,19 @@
+*** Headers/xlib/XftFontInfo.h.orig Sun Feb 2 23:39:29 2003
+--- Headers/xlib/XftFontInfo.h Sun Feb 2 23:39:38 2003
+***************
+*** 29,35 ****
+ // Include this before we include any objC defines, otherwise id is defined
+ #include <X11/Xlib.h>
+ #define id xwindowsid
+! #include <X11/Xft/Xft.h>
+ #undef id
+
+ #include <AppKit/GSFontInfo.h>
+--- 29,35 ----
+ // Include this before we include any objC defines, otherwise id is defined
+ #include <X11/Xlib.h>
+ #define id xwindowsid
+! #include <X11/Xft1/Xft.h>
+ #undef id
+
+ #include <AppKit/GSFontInfo.h>
diff --git a/dev-util/gnustep-back/gnustep-back-0.8.3.ebuild b/dev-util/gnustep-back/gnustep-back-0.8.3.ebuild
new file mode 100644
index 000000000000..d3ee6c5d5a84
--- /dev/null
+++ b/dev-util/gnustep-back/gnustep-back-0.8.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-back/gnustep-back-0.8.3.ebuild,v 1.1 2003/02/04 19:07:02 raker Exp $
+
+inherit base
+
+DESCRIPTION="GNUstep GUI backend"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+LICENSE="LGPL"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc"
+DEPEND=">=dev-util/gnustep-gui-0.8.3
+ >=media-libs/tiff-3.5.7
+ >=media-libs/jpeg-6b-r2
+ x11-base/xfree"
+S=${WORKDIR}/${P}
+PATCHES="${FILESDIR}/${P}.xft1.patch"
+
+src_compile() {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ ./configure \
+ --prefix=/usr/GNUstep \
+ --with-jpeg-library=/usr/lib \
+ --with-jpeg-include=/usr/include \
+ --with-tiff-library=/usr/lib \
+ --with-tiff-include=/usr/include \
+ --with-x \
+ || die "configure failed"
+
+ #--with-include-flags="-I/usr/include/freetype2" \
+
+ make || die
+
+}
+
+src_install () {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ make \
+ GNUSTEP_INSTALLATION_DIR=${D}/usr/GNUstep/System \
+ INSTALL_ROOT_DIR=${D} \
+ install || die "install failed"
+
+}