summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/ed/ChangeLog5
-rw-r--r--sys-apps/ed/Manifest14
-rw-r--r--sys-apps/ed/ed-0.2-r4.ebuild11
3 files changed, 23 insertions, 7 deletions
diff --git a/sys-apps/ed/ChangeLog b/sys-apps/ed/ChangeLog
index 80ed1a216392..2bcde8dca5d1 100644
--- a/sys-apps/ed/ChangeLog
+++ b/sys-apps/ed/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/ed
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.18 2004/10/10 03:06:51 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.19 2004/12/06 05:44:29 vapier Exp $
+
+ 06 Dec 2004; Mike Frysinger <vapier@gentoo.org> ed-0.2-r4.ebuild:
+ cross-compile fixes
09 Oct 2004; Tom Gall <tgall@gentoo.org> ed-0.2-r4.ebuild:
stable on ppc64, bug #66400
diff --git a/sys-apps/ed/Manifest b/sys-apps/ed/Manifest
index 14ccacae0c5b..7890ad871371 100644
--- a/sys-apps/ed/Manifest
+++ b/sys-apps/ed/Manifest
@@ -1,6 +1,16 @@
-MD5 7ef307f4200a7ab4dae50883573e7628 ChangeLog 2026
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 e3353f5534ef5b92535659adb87401ff ChangeLog 2118
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 61263cde96502345b04133b332408ceb ed-0.2-r4.ebuild 1107
+MD5 f5147426511dad3b44513b3d9d8a08a5 ed-0.2-r4.ebuild 1304
MD5 1b60eebda7e05a6a35164bc4b23ac8ff files/digest-ed-0.2-r4 58
MD5 549e2478edb18002261ae5dd055bcf5b files/0.2-info-dir.patch 373
MD5 e7e2248f9baa76de3db8210298e0d79e files/0.2-mkstemp.patch 738
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFBs/HWroRuSHgZdywRAnf1AJ4w+zvgZUjF5+FMKNVgm2Vc7DirAQCeKHQ3
+SXGHOuXX5tedmU4RnmMISoo=
+=8own
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/ed/ed-0.2-r4.ebuild b/sys-apps/ed/ed-0.2-r4.ebuild
index 4e367a86585b..03a99b0daa2b 100644
--- a/sys-apps/ed/ed-0.2-r4.ebuild
+++ b/sys-apps/ed/ed-0.2-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-0.2-r4.ebuild,v 1.10 2004/11/12 15:53:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-0.2-r4.ebuild,v 1.11 2004/12/06 05:44:29 vapier Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Your basic line editor"
HOMEPAGE="http://www.gnu.org/software/ed/"
@@ -21,16 +21,19 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PV}-info-dir.patch
epatch ${FILESDIR}/${PV}-mkstemp.patch
+ WANT_AUTOCONF=2.1 autoconf || die "autoconf failed"
}
src_compile() {
+ export CC="$(tc-getCC)" RANLIB="$(tc-getRANLIB)"
# very old configure script ... econf wont work
local myconf="--prefix=/ --host=${CHOST}"
- [ ! -z "${CBUILD}" ] && myconf="${myconf} --build=${CBUILD}"
+ [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
+ [[ -n ${CTARGET} ]] && myconf="${myconf} --target=${CTARGET}"
myconf="${myconf} ${EXTRA_ECONF}"
echo "./configure ${myconf}"
./configure ${myconf} || die
- emake || die
+ emake AR="$(tc-getAR)" || die
}
src_install() {