summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/ac-sources/ac-sources-2.4.20_pre102.ebuild37
-rw-r--r--sys-kernel/ac-sources/files/digest-ac-sources-2.4.20_pre1023
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/ac-sources/ac-sources-2.4.20_pre102.ebuild b/sys-kernel/ac-sources/ac-sources-2.4.20_pre102.ebuild
new file mode 100644
index 000000000000..11e4eddd592a
--- /dev/null
+++ b/sys-kernel/ac-sources/ac-sources-2.4.20_pre102.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ac-sources/ac-sources-2.4.20_pre102.ebuild,v 1.1 2002/10/14 20:19:51 lostlogic Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.19"
+KV="2.4.20-pre10-ac2"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="-pre10-ac2"
+
+DESCRIPTION="Full sources for Alan Cox's Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+http://www.kernel.org/pub/linux/kernel/v2.4/testing/patch-${KV/-ac2/}.bz2
+http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.4/2.4.20/patch-${KV}.bz2"
+
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+ bzcat ${DISTDIR}/patch-${KV/-ac2/}.bz2|patch -p1 || die "-marcelo patch failed"
+ bzcat ${DISTDIR}/patch-${KV}.bz2|patch -p1 || die "-ac patch failed"
+
+ kernel_universal_unpack
+}
+
diff --git a/sys-kernel/ac-sources/files/digest-ac-sources-2.4.20_pre102 b/sys-kernel/ac-sources/files/digest-ac-sources-2.4.20_pre102
new file mode 100644
index 000000000000..fac5b88199f9
--- /dev/null
+++ b/sys-kernel/ac-sources/files/digest-ac-sources-2.4.20_pre102
@@ -0,0 +1,3 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 cbea176bdb3f0e653cdd2a2419404b32 patch-2.4.20-pre10.bz2 3774466
+MD5 5e1f0cd8e5599a69f49af185b0a47629 patch-2.4.20-pre10-ac2.bz2 1338719