summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/sptk/ChangeLog8
-rw-r--r--dev-cpp/sptk/Manifest4
-rw-r--r--dev-cpp/sptk/files/digest-sptk-2.2.11
-rw-r--r--dev-cpp/sptk/sptk-2.2.1.ebuild44
4 files changed, 55 insertions, 2 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 8d133243ca63..d38cc727cb7f 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.1 2004/08/16 02:02:40 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.2 2004/08/19 06:33:45 iluxa Exp $
+
+*sptk-2.2.1 (18 Aug 2004)
+
+ 18 Aug 2004; Ilya A. Volynets-Evenbach <iluxa@gentoo.org>
+ +sptk-2.2.1.ebuild:
+ New version compiles propperly without FLTK.
*sptk-2.2 (15 Aug 2004)
diff --git a/dev-cpp/sptk/Manifest b/dev-cpp/sptk/Manifest
index ab2400e691ca..b91ff00c33ea 100644
--- a/dev-cpp/sptk/Manifest
+++ b/dev-cpp/sptk/Manifest
@@ -1,4 +1,6 @@
MD5 2ee4204e428d4ba552dccc45b00bc90b sptk-2.2.ebuild 1080
-MD5 674ed53561b2df1f902a458c17ec44b9 ChangeLog 743
+MD5 3c971004c814fed0f83783cb08aa7d8b sptk-2.2.1.ebuild 1076
+MD5 03b33c10237c49eefa99a180286ac512 ChangeLog 900
MD5 623669b964009bb2a2adfc367f12d072 metadata.xml 334
+MD5 005ad61b10481108e76f80f21470a05d files/digest-sptk-2.2.1 60
MD5 ca482c4334f36836fb9377c2009ce95f files/digest-sptk-2.2 58
diff --git a/dev-cpp/sptk/files/digest-sptk-2.2.1 b/dev-cpp/sptk/files/digest-sptk-2.2.1
new file mode 100644
index 000000000000..bf78e8f5c240
--- /dev/null
+++ b/dev-cpp/sptk/files/digest-sptk-2.2.1
@@ -0,0 +1 @@
+MD5 2a4391bf66217cfcbfad3acce45d0088 sptk-2.2.1.tgz 3634334
diff --git a/dev-cpp/sptk/sptk-2.2.1.ebuild b/dev-cpp/sptk/sptk-2.2.1.ebuild
new file mode 100644
index 000000000000..4ceb10925abf
--- /dev/null
+++ b/dev-cpp/sptk/sptk-2.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-2.2.1.ebuild,v 1.1 2004/08/19 06:33:45 iluxa Exp $
+
+IUSE="fltk odbc"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://sptk.tts-sf.com/${P}.tgz"
+HOMEPAGE="http://sptk.tts-sf.com"
+
+SLOT="2"
+LICENSE="FLTK | GPL-2"
+KEYWORDS="-* ~x86 ~sparc ~mips"
+
+DEPEND="fltk? ( x11-libs/fltk )
+ odbc? ( >=dev-db/unixODBC-2.2.8 )"
+
+src_compile() {
+
+ local myconf
+ myconf="--enable-shared"
+
+ use odbc || myconf="${myconf} --disable-odbc" #default enabled
+ use fltk || myconf="${myconf} --disable-fltk"
+
+ econf \
+ --prefix=/usr \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ einstall \
+ includedir=${D}/usr/include/sptk \
+ libdir=${D}/usr/lib || die "Installation Failed"
+
+ dodoc CHANGES COPYING README
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/sptk/* ${D}/usr/share/doc/${PF}/html
+ rmdir ${D}/usr/share/doc/sptk
+}