summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/sitecopy/Manifest4
-rw-r--r--net-misc/sitecopy/files/digest-sitecopy-0.12.11
-rw-r--r--net-misc/sitecopy/sitecopy-0.12.1.ebuild42
3 files changed, 45 insertions, 2 deletions
diff --git a/net-misc/sitecopy/Manifest b/net-misc/sitecopy/Manifest
index 245ef3b6d8cd..dc0b0678a726 100644
--- a/net-misc/sitecopy/Manifest
+++ b/net-misc/sitecopy/Manifest
@@ -1,7 +1,7 @@
-MD5 00db1d671b9cc9681e014667281147eb ChangeLog 1333
+MD5 55d752d08257016958c5a67b89b8d5fd ChangeLog 1523
MD5 187f73bae3eeae7871f2bb88fa2b53ab sitecopy-0.10.12-r1.ebuild 996
MD5 d64c12eed3c7abbcdfba85a5486b5bfc sitecopy-0.11.4.ebuild 831
-MD5 c6b5f195933bc9aff491d34053195247 sitecopy-0.12.1.ebuild 1148
+MD5 d74c405b1ad9dcd8c36435490ff14fc1 sitecopy-0.12.1.ebuild 1145
MD5 09b3e7444248285b787fa3635d41aedc files/digest-sitecopy-0.10.12-r1 68
MD5 33ca043ac941860223413b8d1ddc5d1f files/digest-sitecopy-0.11.4 67
MD5 3ee0433186f6f3224dff93ab6818a119 files/digest-sitecopy-0.12.1 67
diff --git a/net-misc/sitecopy/files/digest-sitecopy-0.12.1 b/net-misc/sitecopy/files/digest-sitecopy-0.12.1
new file mode 100644
index 000000000000..789f12dca74e
--- /dev/null
+++ b/net-misc/sitecopy/files/digest-sitecopy-0.12.1
@@ -0,0 +1 @@
+MD5 70c6ac710f5f21015a0c38a2b653a0a2 sitecopy-0.12.1.tar.gz 756199
diff --git a/net-misc/sitecopy/sitecopy-0.12.1.ebuild b/net-misc/sitecopy/sitecopy-0.12.1.ebuild
new file mode 100644
index 000000000000..ee20d033dd4d
--- /dev/null
+++ b/net-misc/sitecopy/sitecopy-0.12.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/sitecopy-0.12.1.ebuild,v 1.1 2003/04/28 18:37:19 mholzer Exp $
+
+IUSE="ssl xml xml2"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="sitecopy is for easily maintaining remote web sites"
+SRC_URI="http://www.lyra.org/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.lyra.org/sitecopy/"
+KEYWORDS="~x86 ~ppc ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ xml? ( dev-libs/libxml )
+ dev-libs/libxml2
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+ local myconf=""
+ if [ "`use xml`" ] && [ "`use xml2`" ] ; then
+ myconf="${myconf} --with-libxml2 --without-libxml1"
+ else
+ use xml \
+ && myconf="${myconf} --with-libxml1" \
+ || myconf="${myconf} --without-libxml1"
+ use xml2 \
+ && myconf="${myconf} --with-libxml2" \
+ || myconf="${myconf} --without-libxml2"
+ fi
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+ econf ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+}