summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lisp/bigloo-lib/ChangeLog18
-rw-r--r--dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild60
-rw-r--r--dev-lisp/bigloo-lib/files/digest-bigloo-lib-0.171
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-lisp/bigloo-lib/ChangeLog b/dev-lisp/bigloo-lib/ChangeLog
new file mode 100644
index 000000000000..0fbffc6de2d4
--- /dev/null
+++ b/dev-lisp/bigloo-lib/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for dev-lisp/bigloo-lib
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo-lib/ChangeLog,v 1.1 2002/04/13 23:16:55 karltk Exp $
+
+*bigloo-lib-0.17 (13 Apr 2002)
+
+ 13 Apr 2002; Karl Trygve Kalleberg <karltk@gentoo.org> bigloo-lib-0.17.ebuild files/digest-bigloo-lib-0.17:
+
+ Bigloo-lib is a set of libraries for Bigloo, the Scheme programming language
+ compiler (http://kaolin.unice.fr/bigloo/). Most of the libraries are
+ ready-to-use interfaces for various C-based packages, such as C runtime
+ library, Gtk++, LDAP client API or XML parser API. Other are done entirely
+ in `pure Scheme', such as HTTP library and NODE library.
+
+ Besides, the bigloo-lib provides a comfortable framework to configure,
+ compile, install and deploy Bigloo (in particular, system-dependent)
+ libraries, so it is quite a good place to put code created by other Bigloo
+ developers.
diff --git a/dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild b/dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild
new file mode 100644
index 000000000000..6c0054dd1ada
--- /dev/null
+++ b/dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo-lib/bigloo-lib-0.17.ebuild,v 1.1 2002/04/13 23:16:55 karltk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Bigloo support libraries"
+SRC_URI="http://prdownloads.sourceforge.net/bigloo-lib/${P}.tar.gz"
+HOMEPAGE="http://bigloo-lib.sf.net"
+
+DEPEND=">=dev-lisp/bigloo-2.4
+ gd? ( >=media-libs/libgd-1.8.3 )
+ X? ( virtual/x11 )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( x11-libs/gtk+-2* )
+ ldap? ( >=net-nds/openldaap/2.0.18 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ gettext? ( >=sys-devel/gettext-0.11.1 )
+ "
+#RDEPEND=""
+
+src_compile() {
+ local myc
+ # readline support is flaky
+# myc="--with-commandline"
+ use gd && myc="$myc --with-gd" || myc="$myc --without-gd"
+ use X && myc="$myc --with-x" || myc="$myc --without-x"
+ use gtk && myc="$myc --with-gtk" || myc="$myc --without-gtk"
+ use gtk2 && myc="$myc --with-gtk2" || myc="$myc --without-gtk2"
+ use ldap && myc="$myc --with-ldap" || myc="$myc --without-ldap"
+ use nls && myc="$myc --with-iconv" || myc="$myc --without-nls"
+ use gettext && myc="$myc --with-gettext" || myc="$myc --without-gettext"
+ use ipcs && myc="$myc --with-ipcs" || myc="$myc --without-ipcs"
+
+ # gdbm support doesn't work
+# use gdbm && myc="$myc --with-gdbm" || myc="$myc --without-gdbm"
+ myc="$myc --without-gdbm"
+
+ use mysql && myc="$myc --with-mysql" || myc="$myc --without-mysql"
+ use postgres && myc="$myc --with-postgres" || myc="$myc --without-postgres"
+ use expat && myc="$myc --with-expat" || myc="$myc --without-expat"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $myc || die "./configure failed"
+ emake || die
+ #make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ #make \
+ # prefix=${D}/usr \
+ # mandir=${D}/usr/share/man \
+ # infodir=${D}/usr/share/info \
+ # install || die
+}
diff --git a/dev-lisp/bigloo-lib/files/digest-bigloo-lib-0.17 b/dev-lisp/bigloo-lib/files/digest-bigloo-lib-0.17
new file mode 100644
index 000000000000..d290a17e8b61
--- /dev/null
+++ b/dev-lisp/bigloo-lib/files/digest-bigloo-lib-0.17
@@ -0,0 +1 @@
+MD5 d540c43d31e759bc076901a5175a0e63 bigloo-lib-0.17.tar.gz 660118