summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/file/file-4.17-r1.ebuild11
-rw-r--r--sys-apps/gawk/gawk-3.1.5-r2.ebuild34
2 files changed, 19 insertions, 26 deletions
diff --git a/sys-apps/file/file-4.17-r1.ebuild b/sys-apps/file/file-4.17-r1.ebuild
index 2e5c98bd5404..dd7e9d3e38a9 100644
--- a/sys-apps/file/file-4.17-r1.ebuild
+++ b/sys-apps/file/file-4.17-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.17-r1.ebuild,v 1.14 2006/07/30 23:23:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.17-r1.ebuild,v 1.15 2006/08/21 02:04:32 vapier Exp $
inherit eutils distutils libtool
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="python build"
+IUSE="python"
DEPEND=""
@@ -40,17 +40,14 @@ src_compile() {
econf --datadir=/usr/share/misc || die
emake || die "emake failed"
- use build && return 0
use python && cd python && distutils_src_compile
}
src_install() {
make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog MAINT README
- if ! use build ; then
- dodoc ChangeLog MAINT README
- use python && cd python && distutils_src_install
- fi
+ use python && cd python && distutils_src_install
}
pkg_postinst() {
diff --git a/sys-apps/gawk/gawk-3.1.5-r2.ebuild b/sys-apps/gawk/gawk-3.1.5-r2.ebuild
index 9c4cbd137693..a2e2902c7672 100644
--- a/sys-apps/gawk/gawk-3.1.5-r2.ebuild
+++ b/sys-apps/gawk/gawk-3.1.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.5-r2.ebuild,v 1.9 2006/08/13 00:16:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.5-r2.ebuild,v 1.10 2006/08/21 02:03:44 vapier Exp $
inherit eutils toolchain-funcs multilib
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/gawk/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm hppa ~ia64 m68k ~mips ppc ~ppc-macos ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls build"
+IUSE="nls"
RDEPEND=""
DEPEND="${RDEPEND}
@@ -97,21 +97,17 @@ src_install() {
# We do not want 'acconfig.h' in there ...
rm -f "${D}"/usr/include/awk/acconfig.h
- if ! use build ; then
- cd "${S}"
- rm -f "${D}"/usr/share/man/man1/pgawk.1
- dosym gawk.1.gz /usr/share/man/man1/pgawk.1.gz
- [[ ${USERLAND} == "GNU" ]] && dosym gawk.1.gz /usr/share/man/man1/awk.1.gz
- dodoc AUTHORS ChangeLog FUTURES LIMITATIONS NEWS PROBLEMS POSIX.STD README
- docinto README_d
- dodoc README_d/*
- docinto awklib
- dodoc awklib/ChangeLog
- docinto pc
- dodoc pc/ChangeLog
- docinto posix
- dodoc posix/ChangeLog
- else
- rm -r "${D}"/usr/share
- fi
+ cd "${S}"
+ rm -f "${D}"/usr/share/man/man1/pgawk.1
+ dosym gawk.1.gz /usr/share/man/man1/pgawk.1.gz
+ [[ ${USERLAND} == "GNU" ]] && dosym gawk.1.gz /usr/share/man/man1/awk.1.gz
+ dodoc AUTHORS ChangeLog FUTURES LIMITATIONS NEWS PROBLEMS POSIX.STD README
+ docinto README_d
+ dodoc README_d/*
+ docinto awklib
+ dodoc awklib/ChangeLog
+ docinto pc
+ dodoc pc/ChangeLog
+ docinto posix
+ dodoc posix/ChangeLog
}