summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/nano/ChangeLog9
-rw-r--r--app-editors/nano/Manifest4
-rw-r--r--app-editors/nano/files/digest-nano-1.3.71
-rw-r--r--app-editors/nano/nano-1.3.7.ebuild69
4 files changed, 80 insertions, 3 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 87c1a8e928ca..654a02004987 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/nano
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.69 2005/03/22 06:22:30 vapier Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.70 2005/04/14 03:24:21 vapier Exp $
+
+*nano-1.3.7 (14 Apr 2005)
+
+ 14 Apr 2005; Mike Frysinger <vapier@gentoo.org> +nano-1.3.7.ebuild:
+ Version bump.
*nano-1.3.6 (22 Mar 2005)
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 62fffd91b188..7d660877eac9 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,6 +1,7 @@
-MD5 5808e64bba48848f9c71674fc5b40cac ChangeLog 7962
+MD5 2d77194626a74fcfc52715f08d4bf822 ChangeLog 8076
MD5 b297797b490f7c6ca8d5f40f2d6347cc metadata.xml 1015
MD5 d8d8da511c4fb40d0ae643b79006aadb nano-1.2.4.ebuild 1401
+MD5 1e70fc24cf18ec67d15ec733b234ca23 nano-1.3.7.ebuild 1704
MD5 ce43a4101c4d4b6915478aee57aea74c nano-1.3.4.ebuild 1577
MD5 f08ac6a2355e4a42a301f144d0ca2c52 nano-1.3.5.ebuild 1728
MD5 272ac1a979c65ea95553b5288a65f26e nano-1.3.6.ebuild 1741
@@ -15,6 +16,7 @@ MD5 1dc6cc0231305e0268bd17287b429db2 files/nanorc-gentoo 1866
MD5 eabfefc7d73cdd882c2ac8ca7a676970 files/nanorc-man 330
MD5 061dd7ec0e2fef8722c1c46d2a09b327 files/nanorc-patch 258
MD5 9ecacdb9e41a6ddb3200113238ca4b2b files/nanorc-sh 646
+MD5 959e0d50769b5362d326d0d26809ff02 files/digest-nano-1.3.7 63
MD5 95e2a2065a0c2ff580dcf645fba2de1e files/digest-nano-1.3.4 62
MD5 4cf6c77ed7c28d94c8de44d8318176c3 files/1.3.4-nomac.patch 511
MD5 c3684059e73752ce1f114e768ecbaa2b files/1.3.4-nanobrack.patch 557
diff --git a/app-editors/nano/files/digest-nano-1.3.7 b/app-editors/nano/files/digest-nano-1.3.7
new file mode 100644
index 000000000000..b89307b34aa4
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.3.7
@@ -0,0 +1 @@
+MD5 2d47badfae9f45174cf1ec69b742f961 nano-1.3.7.tar.gz 1008999
diff --git a/app-editors/nano/nano-1.3.7.ebuild b/app-editors/nano/nano-1.3.7.ebuild
new file mode 100644
index 000000000000..3e41789b7445
--- /dev/null
+++ b/app-editors/nano/nano-1.3.7.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.7.ebuild,v 1.1 2005/04/14 03:24:21 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-${PV/_}
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+SRC_URI="http://www.nano-editor.org/dist/v1.3/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sh ~sparc ~x86"
+IUSE="nls build spell justify debug slang ncurses nomac"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ slang? ( sys-libs/slang )"
+PROVIDE="virtual/editor"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use nomac && epatch "${FILESDIR}"/${PN}-1.3.6-nomac.patch
+}
+
+src_compile() {
+ local myconf=""
+ use build && myconf="${myconf} --disable-wrapping-as-root"
+ use ncurses || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ $(use_enable spell) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use build ; then
+ rm -rf "${D}"/usr/share
+ else
+ cat "${FILESDIR}"/nanorc-* >> doc/nanorc.sample
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+ fi
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}
+
+pkg_postinst() {
+ einfo "More helpful info about nano, visit the GDP page:"
+ einfo "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
+}