summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/celestia/ChangeLog5
-rw-r--r--sci-astronomy/celestia/Manifest10
-rw-r--r--sci-astronomy/celestia/celestia-1.4.0.ebuild13
3 files changed, 18 insertions, 10 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index 36a22617e38f..890ae436a2d2 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.7 2006/01/17 05:58:44 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.8 2006/01/19 07:31:12 morfic Exp $
+
+ 19 Jan 2006; Daniel Goller <morfic@gentoo.org> celestia-1.4.0.ebuild:
+ Fixing bug #119339 while taking care of access violations
17 Jan 2006; Daniel Goller <morfic@gentoo.org> celestia-1.4.0.ebuild:
Fixing Access Violations, closing bug #119189
diff --git a/sci-astronomy/celestia/Manifest b/sci-astronomy/celestia/Manifest
index cef63ecf4d3d..1c269347a621 100644
--- a/sci-astronomy/celestia/Manifest
+++ b/sci-astronomy/celestia/Manifest
@@ -1,9 +1,9 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 1303ff5c9d63575980ca793e0c650ed3 ChangeLog 6460
+MD5 3c0524750e3325da2859c6757b117539 ChangeLog 6593
MD5 6be90f964bc6ca0195b0623338dfd1f0 celestia-1.3.2.ebuild 3063
-MD5 45a1093958a7d5955633dc737b3a069f celestia-1.4.0.ebuild 2645
+MD5 21db3a76a66261e85edf5922c752199d celestia-1.4.0.ebuild 2893
MD5 f659f2616eeaaa4d3b6422e586d2bfa2 files/celestia-1.3.2-noarts.patch 3566
MD5 d4ff8e51fb3a546279e7442cf24e07d7 files/digest-celestia-1.3.2 68
MD5 8e1dfea9c274b2242b921a467ec1d54b files/digest-celestia-1.4.0 68
@@ -12,7 +12,7 @@ MD5 1b55bd73a1313e288a88762af6cd0fb7 metadata.xml 330
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDzIes/aM9DdBw91cRAg9aAKChTpZJYvXd8UhKBYeowNAMiz1U4wCg3Flz
-cOa50F4Gn4lkYiRNf4BnhcA=
-=lEoG
+iD8DBQFDz0BV/aM9DdBw91cRAjC0AJ4wDyZJmR+AGH0+sy6DxZ2TZFpO/wCgy7Kt
+tvt+g3dmwELKmMR3+QN3qBM=
+=1qPc
-----END PGP SIGNATURE-----
diff --git a/sci-astronomy/celestia/celestia-1.4.0.ebuild b/sci-astronomy/celestia/celestia-1.4.0.ebuild
index 4bdeb7d4c2db..27b35598a3b5 100644
--- a/sci-astronomy/celestia/celestia-1.4.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.3 2006/01/17 05:58:44 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.4 2006/01/19 07:31:12 morfic Exp $
inherit eutils flag-o-matic gnome2 kde-functions
@@ -43,8 +43,8 @@ pkg_setup() {
einfo "USE=\"gtk\" detected."
mygui="gtk"
elif use kde && use gnome; then
- einfo "Both gnome and kde support requested. Defaulting to gtk"
- mygui="gtk"
+ einfo "Both gnome and kde support requested. Defaulting to kde"
+ mygui="kde"
else
ewarn "If you want to use the full gui, set USE=\"{kde/gnome/gtk}\""
ewarn "Defaulting to glut support (no GUI)."
@@ -74,11 +74,17 @@ src_compile() {
econf \
--with-${mygui} \
+ --with-pic \
$(use_with arts) \
$(use_with lua) \
$(use_enable threads threading) \
$(use_enable nls) \
|| die "econf failed"
+
+ #fix Makefiles to avoid Access Violations while fixing bug #119339
+ for d in . src data extras textures textures/lores textures/medres textures/hires models shaders fonts po ; do
+ sed -i -e "s#pkgdatadir = /usr/share/celestia#pkgdatadir = ${D}/usr/share/celestia#" $d/Makefile; done
+
emake || die "emake failed"
}
@@ -86,7 +92,6 @@ src_install() {
if [ "${mygui}" = "gnome" ]; then
gnome2_src_install
else
- EXTRA_EINSTALL="pkgdatadir=${D}/usr/share/celestia"
einstall || die "einstall failed"
fi