summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/qt-assistant/ChangeLog8
-rw-r--r--x11-libs/qt-assistant/metadata.xml7
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild86
-rw-r--r--x11-libs/qt-core/ChangeLog8
-rw-r--r--x11-libs/qt-core/metadata.xml2
-rw-r--r--x11-libs/qt-core/qt-core-4.7.0.ebuild164
-rw-r--r--x11-libs/qt-dbus/ChangeLog8
-rw-r--r--x11-libs/qt-dbus/qt-dbus-4.7.0.ebuild39
-rw-r--r--x11-libs/qt-declarative/ChangeLog10
-rw-r--r--x11-libs/qt-declarative/metadata.xml14
-rw-r--r--x11-libs/qt-declarative/qt-declarative-4.7.0.ebuild45
-rw-r--r--x11-libs/qt-demo/ChangeLog8
-rw-r--r--x11-libs/qt-demo/qt-demo-4.7.0.ebuild47
13 files changed, 438 insertions, 8 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 846360f91100..7da9d43072ca 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.84 2010/09/13 21:18:52 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.85 2010/09/21 14:37:38 tampakrap Exp $
+
+*qt-assistant-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-assistant-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-assistant-4.6.2.ebuild:
diff --git a/x11-libs/qt-assistant/metadata.xml b/x11-libs/qt-assistant/metadata.xml
index 26c910d4e964..6bde1b8bb16d 100644
--- a/x11-libs/qt-assistant/metadata.xml
+++ b/x11-libs/qt-assistant/metadata.xml
@@ -5,9 +5,8 @@
<use>
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
- <flag name='trace'>
- Build the qttracereplay utility which is required to play drawings
- recorded with the trace graphicssystem engine
- </flag>
+ <flag name='trace'>Build the qttracereplay utility which is required to
+ play drawings recorded with the trace graphicssystem engine</flag>
+ <flag name='glib'>Enable <pkg>dev-libs/glib</pkg> eventloop support</flag>
</use>
</pkgmetadata>
diff --git a/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
new file mode 100644
index 000000000000..38dfd5d8a26f
--- /dev/null
+++ b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild,v 1.1 2010/09/21 14:37:38 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The assistant help module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +glib trace"
+
+DEPEND="~x11-libs/qt-gui-${PV}[glib=,trace?]
+ ~x11-libs/qt-sql-${PV}[sqlite]
+ ~x11-libs/qt-webkit-${PV}
+ ~x11-libs/qt-declarative-${PV}"
+RDEPEND="${DEPEND}"
+
+# Pixeltool isn't really assistant related, but it relies on
+# the assistant libraries. doc/qch/
+QT4_TARGET_DIRECTORIES="
+ tools/assistant
+ tools/pixeltool
+ tools/qdoc3"
+QT4_EXTRACT_DIRECTORIES="
+ tools/
+ demos/
+ examples/
+ src/
+ include/
+ doc/"
+
+pkg_setup() {
+ use trace && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ tools/qttracereplay"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ ${QT4_EXTRACT_DIRECTORIES}"
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-multimedia -no-qt3support -no-svg"
+ ! use glib && myconf="${myconf} -no-glib"
+ qt4-build_src_configure
+}
+
+src_compile() {
+ # help libQtHelp find freshly built libQtCLucene (bug #289811)
+ export LD_LIBRARY_PATH="${S}/lib:${QTLIBDIR}"
+ export DYLD_LIBRARY_PATH="${S}/lib:${S}/lib/QtHelp.framework"
+
+ qt4-build_src_compile
+
+ # ugly hack to build docs
+ cd "${S}"
+ qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die
+ emake qch_docs || die "emake qch_docs failed"
+ if use doc; then
+ emake docs || die "emake docs failed"
+ fi
+ qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die
+}
+
+src_install() {
+ qt4-build_src_install
+ cd "${S}"
+ emake INSTALL_ROOT="${D}" install_qchdocs \
+ || die "failed to install qch docs"
+ if use doc; then
+ emake INSTALL_ROOT="${D}" install_htmldocs \
+ || die "failed to install htmldocs"
+ fi
+ dobin "${S}"/bin/qdoc3 || die "Failed to install qdoc3"
+ # install correct assistant icon, bug 241208
+ dodir /usr/share/pixmaps/ || die
+ insinto /usr/share/pixmaps/
+ doins tools/assistant/tools/assistant/images/assistant.png || die
+ # Note: absolute image path required here!
+ make_desktop_entry /usr/bin/assistant Assistant \
+ /usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' || die
+}
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index 8eea7a710b18..c86abba1c5df 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.103 2010/09/13 21:19:15 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.104 2010/09/21 14:41:15 tampakrap Exp $
+
+*qt-core-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-core-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-core-4.6.2-r1.ebuild:
diff --git a/x11-libs/qt-core/metadata.xml b/x11-libs/qt-core/metadata.xml
index 37fc862bc54e..3e983c5a5838 100644
--- a/x11-libs/qt-core/metadata.xml
+++ b/x11-libs/qt-core/metadata.xml
@@ -9,5 +9,7 @@
<flag name='optimized-qmake'>Enable qmake optimization</flag>
<flag name='qt3support'>Enable the Qt3Support libraries for Qt4. Note that
this does not mean you can compile pure Qt3 programs with Qt4.</flag>
+ <flag name="private-headers">Install Qt declarative private headers
+ required by Qt-creator QmlDesigner and QmlInspector plugins"</flag>
</use>
</pkgmetadata>
diff --git a/x11-libs/qt-core/qt-core-4.7.0.ebuild b/x11-libs/qt-core/qt-core-4.7.0.ebuild
new file mode 100644
index 000000000000..e02cd4f5aa63
--- /dev/null
+++ b/x11-libs/qt-core/qt-core-4.7.0.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.7.0.ebuild,v 1.1 2010/09/21 14:41:15 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Qt toolkit is a comprehensive C++ application development framework"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="+glib iconv optimized-qmake private-headers qt3support ssl"
+
+RDEPEND="sys-libs/zlib
+ glib? ( dev-libs/glib )
+ ssl? ( dev-libs/openssl )
+ !<x11-libs/qt-4.4.0:4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+PDEPEND="qt3support? ( ~x11-libs/qt-gui-${PV}[glib=,qt3support] )"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/tools/bootstrap
+ src/tools/moc
+ src/tools/rcc
+ src/tools/uic
+ src/corelib
+ src/xml
+ src/network
+ src/plugins/codecs
+ tools/linguist/lconvert
+ tools/linguist/lrelease
+ tools/linguist/lupdate"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/Qt
+ include/QtCore
+ include/QtDeclarative
+ include/QtGui
+ include/QtNetwork
+ include/QtScript
+ include/QtXml
+ src/plugins/plugins.pro
+ src/plugins/qpluginbase.pri
+ src/src.pro
+ src/3rdparty/des
+ src/3rdparty/harfbuzz
+ src/3rdparty/md4
+ src/3rdparty/md5
+ src/3rdparty/sha1
+ src/3rdparty/easing
+ src/3rdparty/zlib_dependency.pri
+ src/declarative
+ src/gui
+ src/script
+ tools/linguist/shared
+ tools/shared/symbian
+ tools/shared/windows
+ translations"
+ qt4-build_pkg_setup
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ ${QT4_EXTRACT_DIRECTORIES}"
+}
+
+src_prepare() {
+ # Don't pre-strip, bug 235026
+ for i in kr jp cn tw ; do
+ echo "CONFIG+=nostrip" >> "${S}"/src/plugins/codecs/${i}/${i}.pro
+ done
+
+ qt4-build_src_prepare
+
+ # bug 172219
+ sed -i -e "s:CXXFLAGS.*=:CXXFLAGS=${CXXFLAGS} :" \
+ "${S}/qmake/Makefile.unix" || die "sed qmake/Makefile.unix CXXFLAGS failed"
+ sed -i -e "s:LFLAGS.*=:LFLAGS=${LDFLAGS} :" \
+ "${S}/qmake/Makefile.unix" || die "sed qmake/Makefile.unix LDFLAGS failed"
+}
+
+src_configure() {
+ unset QMAKESPEC
+
+ myconf="${myconf}
+ $(qt_use glib)
+ $(qt_use iconv)
+ $(qt_use optimized-qmake)
+ $(qt_use ssl openssl)
+ $(qt_use qt3support)"
+
+ myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-gif -no-libpng
+ -no-libmng -no-libjpeg -system-zlib -no-webkit -no-phonon -no-xmlpatterns
+ -no-freetype -no-libtiff -no-accessibility -no-fontconfig -no-opengl
+ -no-svg -no-gtkstyle -no-phonon-backend -no-script -no-scripttools
+ -no-cups -no-xsync -no-xinput -no-multimedia"
+ qt4-build_src_configure
+}
+
+src_compile() {
+ # bug 259736
+ unset QMAKESPEC
+ qt4-build_src_compile
+}
+
+src_install() {
+ dobin "${S}"/bin/{qmake,moc,rcc,uic,lconvert,lrelease,lupdate} || die
+
+ install_directories src/{corelib,xml,network,plugins/codecs}
+
+ emake INSTALL_ROOT="${D}" install_mkspecs || die
+
+ #install private headers
+ if use private-headers; then
+ insinto ${QTHEADERDIR}/QtCore/private
+ find "${S}"/src/corelib -type f -name "*_p.h" -exec doins {} \;
+ fi
+ # use freshly built libraries
+ local DYLD_FPATH=
+ [[ -d "${S}"/lib/QtCore.framework ]] \
+ && DYLD_FPATH=$(for x in "${S}/lib/"*.framework; do echo -n ":$x"; done)
+ DYLD_LIBRARY_PATH="${S}/lib${DYLD_FPATH}" \
+ LD_LIBRARY_PATH="${S}/lib" "${S}"/bin/lrelease translations/*.ts || die
+ insinto ${QTTRANSDIR}
+ doins translations/*.qm || die
+
+ setqtenv
+ fix_library_files
+
+ # List all the multilib libdirs
+ local libdirs=
+ for libdir in $(get_all_libdirs); do
+ libdirs="${libdirs}:/usr/${libdir}/qt4"
+ done
+
+ cat <<-EOF > "${T}/44qt4"
+ LDPATH=${libdirs:1}
+ EOF
+ doenvd "${T}/44qt4"
+
+ dodir /${QTDATADIR}/mkspecs/gentoo
+ mv "${D}"/${QTDATADIR}/mkspecs/qconfig.pri "${D}${QTDATADIR}"/mkspecs/gentoo \
+ || die
+
+ sed -i -e '2a#include <Gentoo/gentoo-qconfig.h>\n' \
+ "${D}${QTHEADERDIR}"/QtCore/qconfig.h \
+ "${D}${QTHEADERDIR}"/Qt/qconfig.h \
+ || die
+ if use glib; then
+ QCONFIG_DEFINE=" $(use glib && echo QT_GLIB)
+ $(use ssl && echo QT_OPENSSL)"
+ install_qconfigs
+ fi
+ # remove .la files
+ find "${D}"${QTLIBDIR} -name "*.la" -print0 | xargs -0 rm
+ # remove some unnecessary headers
+ rm -f "${D}${QTHEADERDIR}"/{Qt,QtCore}/{\
+qatomic_macosx.h,\
+qatomic_windows.h,\
+qatomic_windowsce.h,\
+qt_windows.h}
+
+ keepdir "${QTSYSCONFDIR}"
+}
diff --git a/x11-libs/qt-dbus/ChangeLog b/x11-libs/qt-dbus/ChangeLog
index 8c6285b2dc93..34c0ad26caee 100644
--- a/x11-libs/qt-dbus/ChangeLog
+++ b/x11-libs/qt-dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-dbus
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.70 2010/09/13 21:19:38 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.71 2010/09/21 14:42:24 tampakrap Exp $
+
+*qt-dbus-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-dbus-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> qt-dbus-4.6.2.ebuild:
Stable on alpha, bug #297299
diff --git a/x11-libs/qt-dbus/qt-dbus-4.7.0.ebuild b/x11-libs/qt-dbus/qt-dbus-4.7.0.ebuild
new file mode 100644
index 000000000000..fea61d06e9a5
--- /dev/null
+++ b/x11-libs/qt-dbus/qt-dbus-4.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/qt-dbus-4.7.0.ebuild,v 1.1 2010/09/21 14:42:24 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The DBus module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]
+ >=sys-apps/dbus-1.0.2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/dbus
+ tools/qdbus/qdbus
+ tools/qdbus/qdbusxml2cpp
+ tools/qdbus/qdbuscpp2xml"
+ QCONFIG_ADD="dbus dbus-linked"
+ QCONFIG_DEFINE="QT_DBUS"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/QtCore
+ include/QtDBus
+ include/QtXml
+ src/corelib
+ src/xml"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -dbus-linked"
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-declarative/ChangeLog b/x11-libs/qt-declarative/ChangeLog
new file mode 100644
index 000000000000..8fafe759cc1b
--- /dev/null
+++ b/x11-libs/qt-declarative/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-libs/qt-declarative
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.4 2010/09/21 14:44:04 tampakrap Exp $
+
+*qt-declarative-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-declarative-4.7.0.ebuild, +metadata.xml:
+ Version bump
+
diff --git a/x11-libs/qt-declarative/metadata.xml b/x11-libs/qt-declarative/metadata.xml
new file mode 100644
index 000000000000..e1a08b3f18df
--- /dev/null
+++ b/x11-libs/qt-declarative/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<use>
+ <flag name="private-headers">Install Qt declarative private headers required
+ by Qt-creator QmlDesigner and QmlInspector plugins"</flag>
+ <flag name='exceptions'>Add support for exceptions - like catching them
+ inside the event loop (recommended by Nokia)</flag>
+</use>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/x11-libs/qt-declarative/qt-declarative-4.7.0.ebuild b/x11-libs/qt-declarative/qt-declarative-4.7.0.ebuild
new file mode 100644
index 000000000000..9f9f404c2bdb
--- /dev/null
+++ b/x11-libs/qt-declarative/qt-declarative-4.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/qt-declarative-4.7.0.ebuild,v 1.1 2010/09/21 14:44:04 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Declarative module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="private-headers"
+
+DEPEND="~x11-libs/qt-core-${PV}
+ ~x11-libs/qt-gui-${PV}
+ ~x11-libs/qt-multimedia-${PV}
+ ~x11-libs/qt-opengl-${PV}
+ ~x11-libs/qt-script-${PV}
+ ~x11-libs/qt-sql-${PV}
+ ~x11-libs/qt-svg-${PV}
+ ~x11-libs/qt-webkit-${PV}
+ ~x11-libs/qt-xmlpatterns-${PV}"
+RDEPEND="${DEPEND}"
+
+QCONFIG_ADD="declarative"
+
+QT4_TARGET_DIRECTORIES="
+ src/declarative
+ tools/qml"
+QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+src_configure() {
+ myconf="${myconf} -declarative"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ if use private-headers; then
+ insinto ${QTHEADERDIR}/QtDeclarative/private
+ find "${S}"/src/declarative/ -type f -name "*_p.h" -exec doins {} \;
+ fi
+}
diff --git a/x11-libs/qt-demo/ChangeLog b/x11-libs/qt-demo/ChangeLog
index 6667bf2f4f0c..f598fb9d0716 100644
--- a/x11-libs/qt-demo/ChangeLog
+++ b/x11-libs/qt-demo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-demo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-demo/ChangeLog,v 1.50 2010/09/13 21:20:00 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-demo/ChangeLog,v 1.51 2010/09/21 14:45:36 tampakrap Exp $
+
+*qt-demo-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-demo-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org> qt-demo-4.6.2.ebuild:
Stable on alpha, bug #297299
diff --git a/x11-libs/qt-demo/qt-demo-4.7.0.ebuild b/x11-libs/qt-demo/qt-demo-4.7.0.ebuild
new file mode 100644
index 000000000000..8df1aa86385d
--- /dev/null
+++ b/x11-libs/qt-demo/qt-demo-4.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-demo/qt-demo-4.7.0.ebuild,v 1.1 2010/09/21 14:45:36 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="Demonstration module of the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-assistant-${PV}:${SLOT}
+ ~x11-libs/qt-core-${PV}:${SLOT}
+ ~x11-libs/qt-dbus-${PV}:${SLOT}
+ ~x11-libs/qt-gui-${PV}:${SLOT}
+ ~x11-libs/qt-multimedia-${PV}:${SLOT}
+ ~x11-libs/qt-opengl-${PV}:${SLOT}
+ || ( ~x11-libs/qt-phonon-${PV}:${SLOT} media-sound/phonon )
+ ~x11-libs/qt-script-${PV}:${SLOT}
+ ~x11-libs/qt-sql-${PV}:${SLOT}
+ ~x11-libs/qt-svg-${PV}:${SLOT}
+ ~x11-libs/qt-test-${PV}:${SLOT}
+ ~x11-libs/qt-webkit-${PV}:${SLOT}
+ ~x11-libs/qt-xmlpatterns-${PV}:${SLOT}"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.6-plugandpaint.patch" )
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="demos
+ examples"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ doc/src/images
+ src/
+ include/
+ tools/"
+
+ qt4-build_pkg_setup
+}
+
+src_install() {
+ insinto ${QTDOCDIR}/src
+ doins -r "${S}"/doc/src/images || die
+
+ qt4-build_src_install
+}