summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/xbubble/Manifest3
-rw-r--r--games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch11
-rw-r--r--games-arcade/xbubble/xbubble-0.5.8.ebuild7
3 files changed, 17 insertions, 4 deletions
diff --git a/games-arcade/xbubble/Manifest b/games-arcade/xbubble/Manifest
index bb0d9f862b38..6c9b0ccbd542 100644
--- a/games-arcade/xbubble/Manifest
+++ b/games-arcade/xbubble/Manifest
@@ -1,4 +1,5 @@
MD5 3c6405f2a219ec4201222733417b50fc ChangeLog 707
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 1ce46598d589f4cb50d793e7e196a704 xbubble-0.5.8.ebuild 1031
+MD5 9a5ec69e81aaaa1d6ef52e3ba83058ed xbubble-0.5.8.ebuild 1077
MD5 ad5c558fae56fa370b8e01d0d5656c04 files/digest-xbubble-0.5.8 66
+MD5 85d76fecc99f908fb5ae6d66a43b2332 files/xbubble-0.5.8-xpaths.patch 200
diff --git a/games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch b/games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch
new file mode 100644
index 000000000000..c3dfa83cb5e3
--- /dev/null
+++ b/games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch
@@ -0,0 +1,11 @@
+the x_libraries variable isnt always defined
+http://bugs.gentoo.org/92688
+
+--- configure
++++ configure
+@@ -4511,3 +4511,5 @@
+ fi
++if test x"$x_libraries" != x; then
+ LIBS="-L$x_libraries $LIBS"
++fi
+
diff --git a/games-arcade/xbubble/xbubble-0.5.8.ebuild b/games-arcade/xbubble/xbubble-0.5.8.ebuild
index e671d6c51d34..063daf3be6b2 100644
--- a/games-arcade/xbubble/xbubble-0.5.8.ebuild
+++ b/games-arcade/xbubble/xbubble-0.5.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/xbubble-0.5.8.ebuild,v 1.5 2005/05/15 18:48:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/xbubble-0.5.8.ebuild,v 1.6 2005/05/15 20:45:04 vapier Exp $
-inherit games
+inherit games eutils
DESCRIPTION="a Puzzle Bobble clone similar to Frozen-Bubble"
HOMEPAGE="http://www.nongnu.org/xbubble/"
@@ -10,7 +10,7 @@ SRC_URI="http://www.ibiblio.org/pub/mirrors/gnu/ftp/savannah/files/xbubble/${P}.
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ppc x86"
+KEYWORDS="amd64 ppc x86"
IUSE="nls"
DEPEND="virtual/x11
@@ -19,6 +19,7 @@ DEPEND="virtual/x11
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-xpaths.patch
sed -i \
-e '/^AM_CFLAGS/d' \
src/Makefile.in || die "sed cflags"