summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/libgda/Manifest4
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.91.01
-rw-r--r--gnome-extra/libgda/libgda-0.91.0.ebuild101
-rw-r--r--gnome-extra/libgnomedb/ChangeLog7
-rw-r--r--gnome-extra/libgnomedb/Manifest6
5 files changed, 114 insertions, 5 deletions
diff --git a/gnome-extra/libgda/Manifest b/gnome-extra/libgda/Manifest
index b77e1707a2e8..806da3c135c5 100644
--- a/gnome-extra/libgda/Manifest
+++ b/gnome-extra/libgda/Manifest
@@ -1,9 +1,9 @@
MD5 82a238914314c7c7d2c197ea2f499be1 libgda-0.90.0.ebuild 2625
MD5 8f9f7b7c7813c4a410bdabf61cb18ddb libgda-0.2.96-r2.ebuild 3513
MD5 067794531a44964e1da860622e1c8daf libgda-0.12.1.ebuild 2624
-MD5 7a6c29ce12f676d2c6afdcc9a3d4f45e libgda-0.91.0.ebuild 2449
+MD5 0935218ac73c7ef385567e5811cb68a6 libgda-0.91.0.ebuild 2548
MD5 5ab82f7dadae03ca71999d11372c5569 libgda-0.2.95-r1.ebuild 3309
-MD5 22e3be58bcdb284d2428a4d4929722e8 ChangeLog 3853
+MD5 16e3018596bbc35657220d03b04797c1 ChangeLog 4017
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 40bbf8acf6e08a15e8e61573f6f07724 files/digest-libgda-0.2.95-r1 66
MD5 e92331f7677fcfc3e82541f08676bb32 files/digest-libgda-0.2.96-r2 66
diff --git a/gnome-extra/libgda/files/digest-libgda-0.91.0 b/gnome-extra/libgda/files/digest-libgda-0.91.0
new file mode 100644
index 000000000000..4180d7589cb5
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.91.0
@@ -0,0 +1 @@
+MD5 fcb413d3f26724ff3f6d459c79fa4453 libgda-0.91.0.tar.bz2 986737
diff --git a/gnome-extra/libgda/libgda-0.91.0.ebuild b/gnome-extra/libgda/libgda-0.91.0.ebuild
new file mode 100644
index 000000000000..1b07334e90a5
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.91.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-0.91.0.ebuild,v 1.1 2003/08/28 16:55:40 obz Exp $
+
+IUSE="odbc postgres mysql ldap firebird freetds sqlite mdb oci8 doc"
+
+inherit gnome2
+
+DESCRIPTION="Gnome Database Access Library"
+HOMEPAGE="http://www.gnome-db.org/"
+SLOT="1"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libxml2-2.0
+ >=dev-libs/libxslt-1.0.9
+ >=gnome-base/gnome-vfs-2.0
+ dev-libs/popt
+ sys-libs/ncurses
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2.1 )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ firebird? ( >=dev-db/firebird-1.0 )
+ freetds? ( >=dev-db/freetds-0.5 )
+ sqlite? ( >=dev-db/sqlite-2.4.2 )
+ mdb? ( >=app-office/mdbtools-0.5 )"
+
+DEPEND=">=dev-util/pkgconfig-0.8
+ >=dev-util/intltool-0.22
+ >=sys-devel/gettext-0.11
+ app-text/scrollkeeper
+ doc? ( dev-util/gtk-doc )
+ ${RDEPEND}"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+# problems with parallel builds
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ gnome2_omf_fix ${S}/doc/Makefile.in
+}
+
+src_compile() {
+
+ local myconf
+
+ use mysql \
+ && myconf="${myconf} --with-mysql=/usr" \
+ || myconf="${myconf} --without-mysql"
+
+ use postgres \
+ && myconf="${myconf} --with-postgres=/usr" \
+ || myconf="${myconf} --without-postgres"
+
+ use odbc \
+ && myconf="${myconf} --with-odbc=/usr" \
+ || myconf="${myconf} --without-odbc"
+
+ use ldap \
+ && myconf="${myconf} --with-ldap=/usr" \
+ || myconf="${myconf} --without-ldap"
+
+ use sqlite \
+ && myconf="$myconf --with-sqlite=/usr" \
+ || myconf="$myconf --without-sqlite"
+
+ use freetds \
+ && myconf="$myconf --with-tds=/usr" \
+ || myconf="$myconf --without-tds"
+
+ use firebird \
+ && myconf="${myconf} --with-firebird=/usr" \
+ || myconf="${myconf} --without-firebird"
+
+ use mdb \
+ && myconf="${myconf} --with-mdb=/usr" \
+ || myconf="${myconf} --without-mdb"
+
+ # not in portage (http://linux.techass.com/projects/xdb/)
+ myconf="${myconf} --without-xbase"
+ myconf="${myconf} --without-msql"
+
+ # closed source dbs
+ myconf="${myconf} --without-ibmdb2"
+ myconf="${myconf} --without-sybase"
+ use oci8 || myconf="${myconf} --without-oracle"
+
+ # workaround for readline-4.1 profile - disables building of gda-config-tool
+ if has_version "=sys-libs/readline-4.1*"; then
+ export CONFIG_TOOL_HEADERS="wrong"
+ fi
+
+ gnome2_src_compile ${myconf}
+
+ unset CONFIG_TOOL_HEADERS
+
+}
diff --git a/gnome-extra/libgnomedb/ChangeLog b/gnome-extra/libgnomedb/ChangeLog
index fc77832f2f7d..c8e04a9bd296 100644
--- a/gnome-extra/libgnomedb/ChangeLog
+++ b/gnome-extra/libgnomedb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgnomedb
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgnomedb/ChangeLog,v 1.8 2003/07/05 12:27:43 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgnomedb/ChangeLog,v 1.9 2003/08/28 17:00:42 obz Exp $
+
+*libgnomedb-0.91.0 (29 Aug 2003)
+
+ 29 Aug 2003; Mike Gardiner <obz@gentoo.org> libgnomedb-0.91.0.ebuild:
+ New version
*libgnomedb-0.90.0 (05 Jul 2003)
diff --git a/gnome-extra/libgnomedb/Manifest b/gnome-extra/libgnomedb/Manifest
index 6fd8ef621125..00e4dcb9f831 100644
--- a/gnome-extra/libgnomedb/Manifest
+++ b/gnome-extra/libgnomedb/Manifest
@@ -1,6 +1,8 @@
-MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
-MD5 64aa75ce064c88327d2a59af0a3866ba libgnomedb-0.12.1.ebuild 1285
MD5 f3a5d3625f8c659cd98bd75180accd33 libgnomedb-0.90.0.ebuild 1286
+MD5 64aa75ce064c88327d2a59af0a3866ba libgnomedb-0.12.1.ebuild 1285
+MD5 c19095c4af8d261ded18a1ebe6b8aa19 libgnomedb-0.91.0.ebuild 1200
MD5 c8038c2d8fcb6d2724759437d9aa29a4 ChangeLog 1315
+MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 d48a0cec30d90af0c488dc4dbfc3e1a3 files/digest-libgnomedb-0.12.1 70
MD5 7717e09f4661443921c018c804fa2623 files/digest-libgnomedb-0.90.0 70
+MD5 3d3b7e45fd366f50be6c165f01552c85 files/digest-libgnomedb-0.91.0 70