summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/async_sinatra/ChangeLog10
-rw-r--r--dev-ruby/async_sinatra/Manifest14
-rw-r--r--dev-ruby/async_sinatra/async_sinatra-0.1.5.ebuild38
-rw-r--r--dev-ruby/async_sinatra/metadata.xml5
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-ruby/async_sinatra/ChangeLog b/dev-ruby/async_sinatra/ChangeLog
new file mode 100644
index 000000000000..7e733eb961dd
--- /dev/null
+++ b/dev-ruby/async_sinatra/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/async_sinatra
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/async_sinatra/ChangeLog,v 1.1 2010/04/19 18:09:22 flameeyes Exp $
+
+*async_sinatra-0.1.5 (19 Apr 2010)
+
+ 19 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +async_sinatra-0.1.5.ebuild, +metadata.xml:
+ Initial import of async_sinatra gem.
+
diff --git a/dev-ruby/async_sinatra/Manifest b/dev-ruby/async_sinatra/Manifest
new file mode 100644
index 000000000000..c8b4ab088804
--- /dev/null
+++ b/dev-ruby/async_sinatra/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST async_sinatra-0.1.5.gem 7168 RMD160 8fc5b0393bbbc2d44ce7ca6bad3c1bc1f6d75a78 SHA1 82aedcb789cbb578949439eb1aa396687842c975 SHA256 239bae38c1f66209d3680cb6a0f69a88a8df5f039321f734e479c390aeec4ba3
+EBUILD async_sinatra-0.1.5.ebuild 989 RMD160 e9594e03c5c87613605904aad10d026e16eef626 SHA1 112b66e62de9415a80f641fc124aa443cd815462 SHA256 b8995692f57b0b2e62ff5de9849c0417836a2a23279dc02946a03e8e8de5e94c
+MISC ChangeLog 398 RMD160 2c9e8f13fc1b048416ac6cebee99a6c3b4c537a2 SHA1 a587d4cb1503b383219fe509e271d46745b67496 SHA256 026ba558a879307ebfa5e1bcd0e187418d3bba628cba12481fbeb830f395e9cc
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkvMnGAACgkQAiZjviIA2XgHqgCgyshYLd8XD3SnWgTdh6oa2vdh
+B7YAoOvdjCF8Wqda5aSyDYUrHp2l5H3s
+=iGBE
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/async_sinatra/async_sinatra-0.1.5.ebuild b/dev-ruby/async_sinatra/async_sinatra-0.1.5.ebuild
new file mode 100644
index 000000000000..ca3f4aed783e
--- /dev/null
+++ b/dev-ruby/async_sinatra/async_sinatra-0.1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/async_sinatra/async_sinatra-0.1.5.ebuild,v 1.1 2010/04/19 18:09:22 flameeyes Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+# there are no tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+# the documentation-building requires the gemspec file that is not
+# packaged, this is very unfortunate for us, but the doc does not
+# really tell us much so we're not going out of our way to get this
+# from GIT.
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Asynchronous response API for Sinatra and Thin"
+HOMEPAGE="http://rubyeventmachine.com"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/sinatra-0.9.1
+ >=www-servers/thin-1.2.0'
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/async_sinatra/metadata.xml b/dev-ruby/async_sinatra/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/async_sinatra/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>