summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/ekg/ChangeLog6
-rw-r--r--net-im/ekg/Manifest15
-rw-r--r--net-im/ekg/ekg-1.6_rc1.ebuild17
-rw-r--r--net-im/ekg/files/ekg-1.6_rc1-fpic.patch12
4 files changed, 43 insertions, 7 deletions
diff --git a/net-im/ekg/ChangeLog b/net-im/ekg/ChangeLog
index aa6d4d599093..1221ce2c1298 100644
--- a/net-im/ekg/ChangeLog
+++ b/net-im/ekg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/ekg
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.15 2005/04/01 15:11:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.16 2005/04/14 20:04:15 spock Exp $
+
+ 14 Apr 2005; Michał Januszewski <spock@gentoo.org>
+ +files/ekg-1.6_rc1-fpic.patch, ekg-1.6_rc1.ebuild:
+ Added a patch that should fix bug #88713.
01 Apr 2005; Aron Griffis <agriffis@gentoo.org> ekg-1.6_rc1.ebuild:
stable on ia64
diff --git a/net-im/ekg/Manifest b/net-im/ekg/Manifest
index a8ab6dbd11f7..1aec23750b0b 100644
--- a/net-im/ekg/Manifest
+++ b/net-im/ekg/Manifest
@@ -1,8 +1,19 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 4da0ca4266b73a113cab33b4dba8ef03 ekg-1.4-r1.ebuild 1109
MD5 f43c4aa49c2172a1d4f64eef10bca1f5 ekg-1.5.ebuild 1224
-MD5 01ee257ce38e1d2108682530f03e71b9 ChangeLog 2630
+MD5 0d4a70b72ea80bdc08e60fa04914503d ChangeLog 2779
MD5 d94d306da3804e41296e1bf04c7c9cae metadata.xml 255
-MD5 cd13037fbf825424c254277fe0f757ab ekg-1.6_rc1.ebuild 1226
+MD5 1ff06c041e83532de946499df9a6eebf ekg-1.6_rc1.ebuild 1365
MD5 2bc5f13c9e2cc840a2f8f61fc3a51391 files/digest-ekg-1.4-r1 59
MD5 811e95299fbf084137ceb9b517843924 files/digest-ekg-1.6_rc1 62
MD5 fabb312576862c943792eed047bac7a8 files/digest-ekg-1.5 59
+MD5 7e938e2282dbaf23d5789db2a53c1ddd files/ekg-1.6_rc1-fpic.patch 487
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCXszpchej4aZK9/cRAkGSAJ0VC6iE8YywdIeKVcdqfp25iiauBACfWo3i
+ciMDkPcIZQhXAIMty1tTjgo=
+=1r1l
+-----END PGP SIGNATURE-----
diff --git a/net-im/ekg/ekg-1.6_rc1.ebuild b/net-im/ekg/ekg-1.6_rc1.ebuild
index 22281a319b92..fd4ed6cdd68f 100644
--- a/net-im/ekg/ekg-1.6_rc1.ebuild
+++ b/net-im/ekg/ekg-1.6_rc1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.6_rc1.ebuild,v 1.2 2005/04/01 15:11:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.6_rc1.ebuild,v 1.3 2005/04/14 20:04:15 spock Exp $
-IUSE="ssl ncurses zlib python spell"
+inherit eutils
+
+IUSE="ssl ncurses zlib python spell threads"
DESCRIPTION="EKG (Eksperymentalny Klient Gadu-Gadu) - a text client for Polish instant messaging system Gadu-Gadu"
HOMEPAGE="http://dev.null.pl/ekg/"
@@ -21,14 +23,21 @@ DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
python? ( dev-lang/python )
spell? ( >=app-text/aspell-0.50.3 )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/ekg-1.6_rc1-fpic.patch
+}
+
src_compile() {
- local myconf="--enable-ioctld --enable-shared --with-pthread --enable-dynamic"
+ local myconf="--enable-ioctld --enable-shared --enable-dynamic"
use ssl || myconf="$myconf --disable-openssl"
use ncurses || myconf="$myconf --disable-ui-ncurses --enable-ui-readline"
use zlib || myconf="$myconf --disable-zlib"
use python && myconf="$myconf --with-python"
use spell && myconf="$myconf --enable-aspell"
-
+ use threads && myconf="$myconf --with-pthread"
+
econf ${myconf} || die
emake || die
}
diff --git a/net-im/ekg/files/ekg-1.6_rc1-fpic.patch b/net-im/ekg/files/ekg-1.6_rc1-fpic.patch
new file mode 100644
index 000000000000..ca2da2967c54
--- /dev/null
+++ b/net-im/ekg/files/ekg-1.6_rc1-fpic.patch
@@ -0,0 +1,12 @@
+diff -ur ekg-1.6rc1-old/configure ekg-1.6rc1/configure
+--- ekg-1.6rc1-old/configure 2005-03-20 13:46:53.000000000 +0100
++++ ekg-1.6rc1/configure 2005-04-14 13:15:30.294949464 +0200
+@@ -4224,7 +4224,7 @@
+ echo $ECHO_N "checking if -pthread is sufficient with -shared... $ECHO_C" >&6
+ save_CFLAGS="$CFLAGS"
+ save_LIBS="$LIBS"
+- CFLAGS="-shared -Wl,-z,defs $CFLAGS"
++ CFLAGS="-shared -fPIC -Wl,-z,defs $CFLAGS"
+ ok="no"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"