summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/baselayout/baselayout-1.6.ebuild3
-rw-r--r--sys-apps/devfsd/devfsd-1.3.16-r1.ebuild29
-rw-r--r--sys-apps/devfsd/devfsd-1.3.16.ebuild4
3 files changed, 33 insertions, 3 deletions
diff --git a/sys-apps/baselayout/baselayout-1.6.ebuild b/sys-apps/baselayout/baselayout-1.6.ebuild
index cb9510c95104..34b23b1b5a9b 100644
--- a/sys-apps/baselayout/baselayout-1.6.ebuild
+++ b/sys-apps/baselayout/baselayout-1.6.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.6.ebuild,v 1.5 2001/08/17 22:32:37 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.6.ebuild,v 1.6 2001/08/19 05:03:17 drobbins Exp $
SV=1.1.1
S=${WORKDIR}/rc-scripts-${SV}
DESCRIPTION="Base layout for Gentoo Linux filesystem (incl. initscripts)"
SRC_URI="http://www.ibiblio.org/gentoo/distfiles/rc-scripts-${SV}.tar.bz2"
HOMEPAGE="http://www.gentoo.org"
+RDEPEND=">=sys-apps/devfsd-1.3.16-r1"
#if [ -z "`use bootcd`" ]
#then
diff --git a/sys-apps/devfsd/devfsd-1.3.16-r1.ebuild b/sys-apps/devfsd/devfsd-1.3.16-r1.ebuild
new file mode 100644
index 000000000000..9446ccdc4b49
--- /dev/null
+++ b/sys-apps/devfsd/devfsd-1.3.16-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins et al <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/devfsd/devfsd-1.3.16-r1.ebuild,v 1.1 2001/08/19 05:03:17 drobbins Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Daemon for the Linux Device Filesystem"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/people/rgooch/linux/daemons/devfsd/devfsd-v${PV}.tar.gz"
+HOMEPAGE="http://www.atnf.csiro.au/~rgooch/linux/"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp GNUmakefile GNUmakefile.orig
+ sed -e "s:-O2:${CFLAGS}:g" -e 's:/usr/man:/usr/share/man:' -e '26,28d;6,7d;9d' GNUmakefile.orig > GNUmakefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install () {
+ dodir /sbin /usr/share/man /etc
+ try make PREFIX=${D} install
+ dodir /dev-state
+ insinto /etc
+ doins ${FILESDIR}/devfsd.conf
+}
diff --git a/sys-apps/devfsd/devfsd-1.3.16.ebuild b/sys-apps/devfsd/devfsd-1.3.16.ebuild
index 311cb70d564f..1999f9e38db6 100644
--- a/sys-apps/devfsd/devfsd-1.3.16.ebuild
+++ b/sys-apps/devfsd/devfsd-1.3.16.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins et al <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/devfsd/devfsd-1.3.16.ebuild,v 1.1 2001/08/16 19:11:28 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/devfsd/devfsd-1.3.16.ebuild,v 1.2 2001/08/19 05:03:17 drobbins Exp $
S=${WORKDIR}/${PN}
DESCRIPTION="Daemon for the Linux Device Filesystem"
@@ -31,6 +31,6 @@ src_install () {
}
pkg_postinst () {
- rc-update add devfsd
+ rc-update add devfsd
}