summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--incoming/atlas-3.2.1.ebuild71
-rw-r--r--incoming/gsl-1.0.ebuild49
2 files changed, 0 insertions, 120 deletions
diff --git a/incoming/atlas-3.2.1.ebuild b/incoming/atlas-3.2.1.ebuild
deleted file mode 100644
index 9858214bcf2f..000000000000
--- a/incoming/atlas-3.2.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Tod Neidt <tneidt@fidnet.com>
-# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
-
-
-S=${WORKDIR}/ATLAS
-
-DESCRIPTION="Automatically Tuned Linear Algebra Software (BLAS implementation)."
-
-SRC_URI="http://www.netlib.org/atlas/${PN}${PV}.tgz"
-
-HOMEPAGE="http://math-atlas.sourceforge.net/"
-
-DEPEND="virtual/glibc"
-
-src_compile() {
-
-
-#Make is actually an interactive configuration step.
-#The configuration is highly sensitive to your specific machine.
-#Although it is quite good, it will default to accuracy over speed.
-#Powertweakers might want to configure interactively (also for cross-compile)
-# by uncommenting the next line and commenting the yes ""| make || die line .
-# make || die
-
-#atlas will automatically do a parallel make if possible.
- yes "" | make || die
-
-#Let's go grab the architecture determined by the configure
- cd ${S}/bin
-
-#There might be a better way to do this!?!
-#We can assume "Linux" for a Gentoo Linux system.
-#Need ATLAS_ARCH in src_install too.
- ATLAS_ARCH=$(ls -d Linux*)
-
- cd ${S}
-#This doesn't install into the live / file system.
-#It installs into ${S}/lib/Linux*
- make install arch=${ATLAS_ARCH}
-
-}
-
-src_install () {
-
- cd ${S}/lib/${ATLAS_ARCH}
-
- insinto /usr/lib
- dolib.a libatlas.a libcblas.a libf77blas.a libtstatlas.a
-
-#the atlas liblapack.a library is not a complete lapack library,
-#just the atlas optimizable objects. Store it some place safe
-#where we can grab it when building the complete lapack library.
- insinto /usr/share/${PN}
- doins liblapack.a
-
- cd ${S}/include/${ATLAS_ARCH}
-
- insinto /usr/include
- doins *.h
-
- cd ${S}
-
- dodoc README INSTALL.txt
- dodoc doc/*.txt
- insinto /usr/share/doc/${P}/ps
- doins doc/*.ps
- dodoc bin/${ATLAS_ARCH}/INSTALL_LOG/SUMMARY.LOG
-
-}
diff --git a/incoming/gsl-1.0.ebuild b/incoming/gsl-1.0.ebuild
deleted file mode 100644
index fd13084e5989..000000000000
--- a/incoming/gsl-1.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Tod Neidt <tneidt@fidnet.com>
-# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
-
-
-S=${WORKDIR}/${P}
-
-DESCRIPTION="The GNU Scientific Library"
-
-SRC_URI="http://mirrors.rcn.net/pub/sourceware/gsl/${P}.tar.gz"
-
-HOMEPAGE="http://sources.redhat.com/gsl/"
-
-DEPEND="virtual/glibc"
-
-#RDEPEND=""
-
-src_compile() {
-
-#Avoid locking (can break parallel builds)
- local myconf
- myconf="--disable-libtool-lock"
-
- ./configure --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --host=${CHOST} \
- ${myconf} || die
-
- emake || die
-
-#Uncomment the 'make check ...' line if you want to run the test suite.
-#Note that the check.log file will be several megabytes in size.
-# make check > check.log 2>&1 || die
-
-}
-
-src_install () {
-
- make prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
- dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN-PROBLEMS MACHINES NEWS
-
-}
-