summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/gnome-python-desktop/ChangeLog8
-rw-r--r--dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild12
-rw-r--r--dev-python/gnome-python-extras/ChangeLog8
-rw-r--r--dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild12
4 files changed, 30 insertions, 10 deletions
diff --git a/dev-python/gnome-python-desktop/ChangeLog b/dev-python/gnome-python-desktop/ChangeLog
index ac6a6b26b5db..6152385f510a 100644
--- a/dev-python/gnome-python-desktop/ChangeLog
+++ b/dev-python/gnome-python-desktop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/gnome-python-desktop
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/ChangeLog,v 1.47 2007/11/29 05:39:12 jer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/ChangeLog,v 1.48 2008/02/10 22:04:04 eva Exp $
+
+ 10 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ gnome-python-desktop-2.20.0.ebuild:
+ fix python eclass use, bug #207667
29 Nov 2007; Jeroen Roovers <jer@gentoo.org>
gnome-python-desktop-2.20.0.ebuild:
diff --git a/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild b/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild
index b609decf2b21..2c5092e17dde 100644
--- a/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild
+++ b/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild,v 1.8 2008/01/10 09:45:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/gnome-python-desktop-2.20.0.ebuild,v 1.9 2008/02/10 22:04:04 eva Exp $
inherit gnome2 python virtualx
@@ -38,8 +38,16 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog INSTALL MAINTAINERS NEWS README"
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
src_test() {
- Xmake check || die "tests failed"
+ Xemake check || die "tests failed"
}
src_install() {
diff --git a/dev-python/gnome-python-extras/ChangeLog b/dev-python/gnome-python-extras/ChangeLog
index 1329dfda8733..372fe3bc0cc5 100644
--- a/dev-python/gnome-python-extras/ChangeLog
+++ b/dev-python/gnome-python-extras/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/gnome-python-extras
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.64 2007/10/14 00:22:27 eva Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.65 2008/02/10 22:08:09 eva Exp $
+
+ 10 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ gnome-python-extras-2.19.1-r1.ebuild:
+ fix python eclass use, bug #207667
14 Oct 2007; Gilles Dartiguelongue <eva@gentoo.org>
gnome-python-extras-2.14.2-r1.ebuild:
diff --git a/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild b/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild
index e554703f37ab..6ddbe70649e8 100644
--- a/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild
+++ b/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild,v 1.3 2007/10/14 00:22:27 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild,v 1.4 2008/02/10 22:08:09 eva Exp $
inherit eutils gnome2 python virtualx autotools
@@ -45,11 +45,15 @@ src_unpack() {
# change mozilla to seamonkey
sed -i -e 's:1.2b):1.0.0):;s:mozilla):seamonkey):' configure.ac
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
eautoreconf
}
src_test() {
- Xmake check || die "tests failed"
+ Xemake check || die "tests failed"
}
src_install() {
@@ -63,7 +67,7 @@ src_install() {
pkg_postinst() {
python_version
- python_mod_optimize "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
}
pkg_postrm() {