summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/kasteroids/kasteroids-3.4.0_rc1.ebuild9
-rw-r--r--kde-base/kbounce/kbounce-3.4.0_rc1.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/kde-base/kasteroids/kasteroids-3.4.0_rc1.ebuild b/kde-base/kasteroids/kasteroids-3.4.0_rc1.ebuild
index 7e16fdee545b..dd289eb500f4 100644
--- a/kde-base/kasteroids/kasteroids-3.4.0_rc1.ebuild
+++ b/kde-base/kasteroids/kasteroids-3.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kasteroids/kasteroids-3.4.0_rc1.ebuild,v 1.1 2005/02/27 20:21:31 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kasteroids/kasteroids-3.4.0_rc1.ebuild,v 1.2 2005/02/28 15:34:30 greg_g Exp $
KMNAME=kdegames
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
@@ -14,3 +14,10 @@ OLDDEPEND="~kde-base/libkdegames-$PV"
KMEXTRACTONLY=libkdegames
KMCOPYLIB="libkdegames libkdegames"
+
+pkg_setup() {
+ if ! useq arts; then
+ eerror "${PN} needs the USE=\"arts\" enabled and also the kdelibs compiled with the USE=\"arts\" enabled"
+ die
+ fi
+}
diff --git a/kde-base/kbounce/kbounce-3.4.0_rc1.ebuild b/kde-base/kbounce/kbounce-3.4.0_rc1.ebuild
index 80d65b11cbc7..400cd676b7fc 100644
--- a/kde-base/kbounce/kbounce-3.4.0_rc1.ebuild
+++ b/kde-base/kbounce/kbounce-3.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kbounce/kbounce-3.4.0_rc1.ebuild,v 1.1 2005/02/27 20:21:31 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kbounce/kbounce-3.4.0_rc1.ebuild,v 1.2 2005/02/28 15:35:46 greg_g Exp $
KMNAME=kdegames
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
@@ -14,3 +14,10 @@ OLDDEPEND="~kde-base/libkdegames-$PV"
KMEXTRACTONLY=libkdegames
KMCOPYLIB="libkdegames libkdegames"
+
+pkg_setup() {
+ if ! useq arts; then
+ eerror "${PN} needs the USE=\"arts\" enabled and also the kdelibs compiled with the USE=\"arts\" enabled"
+ die
+ fi
+}