summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sxid/sxid-4.0.4.ebuild')
-rw-r--r--app-admin/sxid/sxid-4.0.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/sxid/sxid-4.0.4.ebuild b/app-admin/sxid/sxid-4.0.4.ebuild
new file mode 100644
index 000000000000..c366f163d2e7
--- /dev/null
+++ b/app-admin/sxid/sxid-4.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/sxid-4.0.4.ebuild,v 1.1 2004/04/22 01:34:39 dragonheart Exp $
+
+DESCRIPTION="suid, sgid file and directory checking"
+SRC_URI="http://www.phunnypharm.org/pub/sxid/${P/-/_}.tar.gz"
+HOMEPAGE="http://freshmeat.net/projects/sxid"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="virtual/glibc"
+
+DEPEND="virtual/glibc
+ sys-apps/sed
+ sys-devel/gcc
+ sys-devel/autoconf"
+
+src_compile() {
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ cd source
+ sed -i s/bindir/sbindir/g Makefile.in
+ cd ..
+
+ econf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README docs/sxid.conf.example docs/sxid.cron.example
+}
+
+pkg_postinst() {
+ einfo "You will need to configure sxid.conf for your system using the manpage and example"
+}