summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/usbview/usbview-1.1-r1.ebuild')
-rw-r--r--app-admin/usbview/usbview-1.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/usbview/usbview-1.1-r1.ebuild b/app-admin/usbview/usbview-1.1-r1.ebuild
new file mode 100644
index 000000000000..666f49ccfdad
--- /dev/null
+++ b/app-admin/usbview/usbview-1.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usbview/usbview-1.1-r1.ebuild,v 1.1 2012/10/21 08:52:57 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Display the topology of devices on the USB bus"
+HOMEPAGE="http://www.kroah.com/linux-usb/"
+SRC_URI="http://www.kroah.com/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-missing-usbfs.patch
+}
+
+src_install() {
+ default
+ doman ${PN}.8
+ doicon usb_icon.xpm
+ make_desktop_entry ${PN} 'USB Viewer' usb_icon
+}