summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pbzip2/files')
-rw-r--r--app-arch/pbzip2/files/pbzip2-1.0.5-fix-stdout-optparse.patch19
-rw-r--r--app-arch/pbzip2/files/pbzip2-1.0.5-ldflags.patch16
-rw-r--r--app-arch/pbzip2/files/pbzip2-1.1.2-makefile.patch62
3 files changed, 62 insertions, 35 deletions
diff --git a/app-arch/pbzip2/files/pbzip2-1.0.5-fix-stdout-optparse.patch b/app-arch/pbzip2/files/pbzip2-1.0.5-fix-stdout-optparse.patch
deleted file mode 100644
index a8de8f5c4165..000000000000
--- a/app-arch/pbzip2/files/pbzip2-1.0.5-fix-stdout-optparse.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- pbzip2-1.0.5-orig/pbzip2.cpp 2009-01-08 23:08:17.000000000 +0200
-+++ pbzip2-1.0.5/pbzip2.cpp 2010-01-29 20:09:22.031524677 +0200
-@@ -2254,7 +2254,7 @@
- FileList[FileListCount] = stdinFile;
- FileListCount++;
- }
-- else if (OutputStdOut == 1)
-+ else if ((decompress == 0) || (OutputStdOut == 1))
- {
- #ifndef WIN32
- if (isatty(fileno(stdout)))
-@@ -2269,6 +2269,7 @@
- // expecting data from stdin
- FileList[FileListCount] = stdinFile;
- FileListCount++;
-+ OutputStdOut = keep = 1;
- }
- else if ((decompress == 1) && (argc == 2))
- {
diff --git a/app-arch/pbzip2/files/pbzip2-1.0.5-ldflags.patch b/app-arch/pbzip2/files/pbzip2-1.0.5-ldflags.patch
deleted file mode 100644
index 3042b30ea275..000000000000
--- a/app-arch/pbzip2/files/pbzip2-1.0.5-ldflags.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- pbzip2-1.0.5/Makefile.orig 2009-03-20 20:52:48.000000000 +0100
-+++ pbzip2-1.0.5/Makefile 2009-03-20 20:54:30.000000000 +0100
-@@ -21,11 +21,11 @@
-
- # Standard pbzip2 compile
- pbzip2: pbzip2.cpp
-- $(CC) $(CFLAGS) $^ -o pbzip2 -pthread -lpthread -lbz2
-+ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o pbzip2 -pthread -lpthread -lbz2
-
- # Choose this if you want to compile in a static version of the libbz2 library
- pbzip2-static: pbzip2.cpp libbz2.a
-- $(CC) $(CFLAGS) $^ -o pbzip2 -pthread -lpthread -I. -L. -lbz2
-+ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o pbzip2 -pthread -lpthread -I. -L. -lbz2
-
- # Install the binary pbzip2 program and man page
- install: pbzip2
diff --git a/app-arch/pbzip2/files/pbzip2-1.1.2-makefile.patch b/app-arch/pbzip2/files/pbzip2-1.1.2-makefile.patch
new file mode 100644
index 000000000000..2457f0197be7
--- /dev/null
+++ b/app-arch/pbzip2/files/pbzip2-1.1.2-makefile.patch
@@ -0,0 +1,62 @@
+--- Makefile.orig 2011-02-21 00:17:16.334746748 +0200
++++ Makefile 2011-02-21 00:19:16.504881112 +0200
+@@ -2,8 +2,6 @@
+ SHELL = /bin/sh
+
+ # Compiler to use
+-CC = g++
+-CFLAGS = -O2
+ #CFLAGS += -g -Wall
+ #CFLAGS += -ansi
+ #CFLAGS += -pedantic
+@@ -12,7 +10,7 @@
+ # Comment out CFLAGS line below for compatability mode for 32bit file sizes
+ # (less than 2GB) and systems that have compilers that treat int as 64bit
+ # natively (ie: modern AIX)
+-CFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++CXXFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+
+ # Uncomment CFLAGS line below if you want to compile pbzip2 without load
+ # average support for systems that do not support it
+@@ -22,10 +20,10 @@
+ #CFLAGS += -DPBZIP_DEBUG
+
+ # Comment out CFLAGS line below to disable pthread semantics in code
+-CFLAGS += -D_POSIX_PTHREAD_SEMANTICS
++CXXFLAGS += -D_POSIX_PTHREAD_SEMANTICS
+
+ # Comment out CFLAGS line below to disable Thread stack size customization
+-CFLAGS += -DUSE_STACKSIZE_CUSTOMIZATION
++CXXFLAGS += -DUSE_STACKSIZE_CUSTOMIZATION
+
+ # Comment out CFLAGS line below to explicity set ignore trailing garbage
+ # default behavior: 0 - disabled; 1 - enabled (ignore garbage by default)
+@@ -34,11 +32,11 @@
+ #CFLAGS += -DIGNORE_TRAILING_GARBAGE=1
+
+ # On some compilers -pthreads
+-CFLAGS += -pthread
++CXXFLAGS += -pthread
+
+ # External libraries
+-LDFLAGS = -lbz2
+-LDFLAGS += -lpthread
++LIBS = -lbz2
++LIBS += -lpthread
+
+ # Where you want pbzip2 installed when you do 'make install'
+ PREFIX = /usr
+@@ -47,11 +45,11 @@
+
+ # Standard pbzip2 compile
+ pbzip2: pbzip2.cpp BZ2StreamScanner.cpp
+- $(CC) $(CFLAGS) $^ -o pbzip2 $(LDFLAGS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $^ $(LIBS) -o pbzip2
+
+ # Choose this if you want to compile in a static version of the libbz2 library
+ pbzip2-static: pbzip2.cpp BZ2StreamScanner.cpp libbz2.a
+- $(CC) $(CFLAGS) $^ -o pbzip2 -I. -L. $(LDFLAGS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $^ $(LIBS) -o pbzip2 -I. -L.
+
+ # Install the binary pbzip2 program and man page
+ install: pbzip2