summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild')
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild
index 7888f73bf1e8..f1452dd5a83d 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild,v 1.3 2007/02/02 20:38:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild,v 1.4 2007/02/03 11:21:02 opfer Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -167,6 +167,9 @@ EOF
}
update-alternatives() {
+ # extract the suffix of the manpages to determine the correct compression program
+ local suffix=`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`
+
# this creates symlinks for binaries and man pages, so the correct ones in a slotted
# environment can be accessed
for i in emacs emacsclient etags ctags b2m ebrowse \
@@ -177,7 +180,7 @@ update-alternatives() {
for j in emacs emacsclient etags ctags
do
- alternatives_auto_makesym "/usr/share/man/man1/$j.1.gz" "/usr/share/man/man1/$j.emacs-${SLOT}*"
+ alternatives_auto_makesym "/usr/share/man/man1/$j.1.${suffix}" "/usr/share/man/man1/$j.emacs-*"
done
}