summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.5.5.ebuild')
-rw-r--r--app-emulation/wine/wine-1.5.5.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-emulation/wine/wine-1.5.5.ebuild b/app-emulation/wine/wine-1.5.5.ebuild
index 25dd113172ba..ffd6338dae51 100644
--- a/app-emulation/wine/wine-1.5.5.ebuild
+++ b/app-emulation/wine/wine-1.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.5.ebuild,v 1.3 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.5.ebuild,v 1.4 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -121,9 +121,14 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785