summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/anthy/anthy-4300b.ebuild')
-rw-r--r--app-i18n/anthy/anthy-4300b.ebuild32
1 files changed, 16 insertions, 16 deletions
diff --git a/app-i18n/anthy/anthy-4300b.ebuild b/app-i18n/anthy/anthy-4300b.ebuild
index 7d14cef9a374..ec564d22d139 100644
--- a/app-i18n/anthy/anthy-4300b.ebuild
+++ b/app-i18n/anthy/anthy-4300b.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4300b.ebuild,v 1.3 2003/09/04 19:15:04 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4300b.ebuild,v 1.4 2003/09/22 00:47:28 usata Exp $
-inherit elisp
+inherit elisp-common
IUSE="emacs"
@@ -16,20 +16,10 @@ SLOT="0"
S="${WORKDIR}/${P}"
-E_DEPEND="emacs? ( ${E_DEPEND} )"
-E_RDEPEND="emacs? ( ${E_DEPEND} )"
-DEPEND="virtual/glibc"
-
-if [ -n "`use emacs`" ] ; then
- SITEFILE="50anthy-gentoo.el"
-else
- pkg_postinst () {
- einfo "Emacs support is disabled."
- }
- pkg_postrm () {
- einfo "Emacs support is disabled."
- }
-fi
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )"
+
+SITEFILE="50anthy-gentoo.el"
src_compile() {
@@ -46,3 +36,13 @@ src_install() {
dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
doc/[A-Z][A-Z]* doc/protocol.txt
}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+}