summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/editor-wrapper/editor-wrapper-3.ebuild')
-rw-r--r--app-misc/editor-wrapper/editor-wrapper-3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/editor-wrapper/editor-wrapper-3.ebuild b/app-misc/editor-wrapper/editor-wrapper-3.ebuild
new file mode 100644
index 000000000000..a8c1e6439c37
--- /dev/null
+++ b/app-misc/editor-wrapper/editor-wrapper-3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/editor-wrapper/editor-wrapper-3.ebuild,v 1.1 2011/08/11 10:47:32 ulm Exp $
+
+EAPI=4
+
+DESCRIPTION="Wrapper scripts that will execute EDITOR or PAGER"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -e 's/@VAR@/EDITOR/g' "${FILESDIR}/${P}.sh" >editor || die
+ sed -e 's/@VAR@/PAGER/g' "${FILESDIR}/${P}.sh" >pager || die
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe editor pager
+ # backwards compatibility
+ dosym editor /usr/libexec/gentoo-editor
+}