summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild')
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild
new file mode 100644
index 000000000000..6a4659723692
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/gentoo-bashcomp/gentoo-bashcomp-20080521-r1.ebuild,v 1.1 2009/02/21 20:29:09 darkside Exp $
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="app-shells/bash-completion"
+
+src_install() {
+ insinto /usr/share/bash-completion
+ doins gentoo || die "doins failed"
+ dodoc AUTHORS ChangeLog NEWS TODO
+}
+
+pkg_postinst() {
+ # can't use bash-completion.eclass.
+ elog "To enable command-line completion for ${PN}, run:"
+ elog
+ elog " eselect bashcomp enable gentoo"
+ elog
+ elog "to install locally, or"
+ elog
+ elog " eselect bashcomp enable --global gentoo"
+ elog
+ elog "to install system-wide."
+}