summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/highlight/highlight-3.4.ebuild')
-rw-r--r--app-text/highlight/highlight-3.4.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-text/highlight/highlight-3.4.ebuild b/app-text/highlight/highlight-3.4.ebuild
new file mode 100644
index 000000000000..2341dc9dd132
--- /dev/null
+++ b/app-text/highlight/highlight-3.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.4.ebuild,v 1.1 2011/06/01 23:54:36 radhermit Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="converts source code to formatted text ((X)HTML, RTF, (La)TeX, XSL-FO, XML) with syntax highlight"
+HOMEPAGE="http://www.andre-simon.de/"
+SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="examples qt4"
+
+DEPEND="dev-lang/lua
+ dev-libs/boost
+ qt4? ( x11-libs/qt-gui:4 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ myhlopts=(
+ "CXX=$(tc-getCXX)"
+ "DESTDIR=${D}"
+ "PREFIX=${EPREFIX}/usr"
+ "doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
+ "conf_dir=${EPREFIX}/etc/highlight/"
+ )
+}
+
+src_prepare() {
+ sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
+ src/core/datadir.cpp || die
+
+ sed -i -e 's:-O2::' \
+ -e 's:CFLAGS:CXXFLAGS:g' \
+ src/makefile || die
+}
+
+src_compile() {
+ emake -f makefile "${myhlopts[@]}"
+ use qt4 && emake -f makefile "${myhlopts[@]}" gui
+}
+
+src_install() {
+ emake -f makefile "${myhlopts[@]}" install
+ use qt4 && emake -f makefile "${myhlopts[@]}" install-gui
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ rm -rf "${D}"/usr/share/doc/${PF}/examples
+ fi
+}