summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libspectre/libspectre-0.2.3.ebuild')
-rw-r--r--app-text/libspectre/libspectre-0.2.3.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/app-text/libspectre/libspectre-0.2.3.ebuild b/app-text/libspectre/libspectre-0.2.3.ebuild
deleted file mode 100644
index 96978e34fea0..000000000000
--- a/app-text/libspectre/libspectre-0.2.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libspectre/libspectre-0.2.3.ebuild,v 1.4 2010/07/27 01:26:40 jer Exp $
-
-inherit autotools eutils
-
-DESCRIPTION="Library to render Postscript documents."
-HOMEPAGE="http://libspectre.freedesktop.org/wiki/"
-SRC_URI="http://libspectre.freedesktop.org/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
-SLOT="0"
-IUSE="debug doc test"
-
-RDEPEND=">=app-text/ghostscript-gpl-8.62"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- test? ( x11-libs/cairo
- dev-util/pkgconfig )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-0.2.0-interix.patch
-
- eautoreconf # need new libtool for interix
-}
-
-src_compile() {
- econf \
- --disable-dependency-tracking \
- $(use_enable debug asserts) \
- $(use_enable debug checks) \
- $(use_enable test) \
- || die "econf failed"
-
- emake || die "emake failed"
-
- if use doc; then
- doxygen || die "doxygen failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc NEWS README TODO || die "installing docs failed"
- if use doc; then
- dohtml -r "${S}"/doc/html/*
- fi
-}