summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/uudeview/ChangeLog18
-rw-r--r--app-text/uudeview/files/digest-uudeview-0.5.131
-rw-r--r--app-text/uudeview/uudeview-0.5.13.ebuild36
3 files changed, 55 insertions, 0 deletions
diff --git a/app-text/uudeview/ChangeLog b/app-text/uudeview/ChangeLog
new file mode 100644
index 000000000000..42467e40c584
--- /dev/null
+++ b/app-text/uudeview/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for app-text/uudeview
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/uudeview/ChangeLog,v 1.1 2002/06/06 08:27:48 george Exp $
+
+*uudeview-0.5.13.ebuild (04 Jun 2002)
+
+ 03 Jun 2002; George Shapovalov <george@gentoo.org> uudeview-0.5.13.ebuild, files/digest-uudeview-0.5.13 :
+
+ First submission
+ From the home page:
+
+ UUDeview is a program that helps you transmit and receive binary files over
+ the Internet, using electronic mail or newsgroups The UUDeview package includes
+ both an encoder and a decoder. The decoder automatically detects the type of
+ encoding used, offering MIME's Base64 and BinHex as well as the popular
+ uuencoding and the less frequently used xxencoding methods. Recently, support
+ for the popular yEnc encoding was also added. The encoder runs the other way
+ around and encodes a binary file for sending it by mail or news.
diff --git a/app-text/uudeview/files/digest-uudeview-0.5.13 b/app-text/uudeview/files/digest-uudeview-0.5.13
new file mode 100644
index 000000000000..f5f64e50b06c
--- /dev/null
+++ b/app-text/uudeview/files/digest-uudeview-0.5.13
@@ -0,0 +1 @@
+MD5 fda32e2de4a6b92eb56f1e286ae3815a uudeview-0.5.13.tar.gz 259627
diff --git a/app-text/uudeview/uudeview-0.5.13.ebuild b/app-text/uudeview/uudeview-0.5.13.ebuild
new file mode 100644
index 000000000000..ff0ab8d33b5b
--- /dev/null
+++ b/app-text/uudeview/uudeview-0.5.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: George Shapovalov <george@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/uudeview/uudeview-0.5.13.ebuild,v 1.1 2002/06/06 08:27:48 george Exp $
+
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="uu, xx, base64, binhex decoder"
+SRC_URI="http://ibiblio.org/pub/Linux/utils/text/${P}.tar.gz"
+HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
+LICENSE="GPL-2"
+DEPEND="tcltk? ( dev-lang/tcl dev-lang/tk )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf
+ use tcltk || myconf="--disable-tcl --disable-tk"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ ${myconf} \
+ --mandir=${D}/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ # Install documentation.
+ dodoc COPYING INSTALL README
+}