summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/sptk/sptk-4.02.ebuild')
-rw-r--r--dev-cpp/sptk/sptk-4.02.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-cpp/sptk/sptk-4.02.ebuild b/dev-cpp/sptk/sptk-4.02.ebuild
index c9e204fd5f00..32085499ad9d 100644
--- a/dev-cpp/sptk/sptk-4.02.ebuild
+++ b/dev-cpp/sptk/sptk-4.02.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-4.02.ebuild,v 1.2 2010/06/17 20:09:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-4.02.ebuild,v 1.3 2010/07/11 06:35:48 ssuominen Exp $
EAPI=1
-inherit cmake-utils
+inherit cmake-utils eutils
IUSE="fltk odbc doc sqlite excel postgres aspell mysql gnutls"
@@ -29,6 +29,12 @@ DEPEND="${RDEPEND}
CMAKE_IN_SOURCE_BUILD=1
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-openssl-1.patch
+}
+
src_compile() {
local mycmakeargs="$(cmake-utils_use_no postgres POSTGRESQL)
$(cmake-utils_use_no mysql MYSQL)