summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/freetds/freetds-0.64.ebuild')
-rw-r--r--dev-db/freetds/freetds-0.64.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-db/freetds/freetds-0.64.ebuild b/dev-db/freetds/freetds-0.64.ebuild
new file mode 100644
index 000000000000..fb4267e117f9
--- /dev/null
+++ b/dev-db/freetds/freetds-0.64.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/freetds/freetds-0.64.ebuild,v 1.1 2006/07/23 19:29:27 chtekk Exp $
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+DESCRIPTION="Tabular Datastream Library."
+HOMEPAGE="http://www.freetds.org/"
+SRC_URI="http://ibiblio.org/pub/Linux/ALPHA/freetds/stable/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="odbc mssql"
+
+DEPEND="odbc? ( dev-db/unixODBC )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf
+ use odbc && myconf="--with-unixodbc=/usr"
+ use mssql && myconf="${myconf} --enable-msdblib"
+ econf --with-tdsver=7.0 ${myconf} --cache-file="${S}/config.cache" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}