summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/libftdi/libftdi-0.17.ebuild')
-rw-r--r--dev-embedded/libftdi/libftdi-0.17.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-embedded/libftdi/libftdi-0.17.ebuild b/dev-embedded/libftdi/libftdi-0.17.ebuild
new file mode 100644
index 000000000000..1f0196d08153
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-0.17.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-0.17.ebuild,v 1.1 2009/12/20 12:39:54 vapier Exp $
+
+EAPI="2"
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
+SRC_URI="http://www.intra2net.com/en/developer/libftdi/download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cxx doc examples python"
+
+RDEPEND="virtual/libusb:0
+ cxx? ( dev-libs/boost )
+ python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # don't bother building examples as we dont want the binaries
+ # installed and the Makefile has broken install targets
+ sed -i '/^SUBDIRS =/s:examples::' Makefile.in
+}
+
+src_configure() {
+ use doc || export ac_cv_path_DOXYGEN=true
+ econf \
+ $(use_enable cxx libftdipp) \
+ $(use_enable python python-binding)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc ChangeLog README
+
+ if use doc ; then
+ doman doc/man/man3/*
+ dohtml doc/html/*
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}