summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hs3/hs3-0.5.6.ebuild')
-rw-r--r--dev-haskell/hs3/hs3-0.5.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/hs3/hs3-0.5.6.ebuild b/dev-haskell/hs3/hs3-0.5.6.ebuild
new file mode 100644
index 000000000000..c53aeaec74af
--- /dev/null
+++ b/dev-haskell/hs3/hs3-0.5.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs3/hs3-0.5.6.ebuild,v 1.1 2011/12/04 18:24:28 slyfox Exp $
+
+# ebuild generated by hackport 0.2.14
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+MY_PN="hS3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Interface to Amazon's Simple Storage Service (S3)"
+HOMEPAGE="http://gregheartsfield.com/hS3/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/crypto-4.1.0
+ dev-haskell/dataenc
+ >=dev-haskell/http-4000.0.0
+ =dev-haskell/hxt-9*
+ >=dev-haskell/missingh-0.18.6
+ dev-haskell/network
+ dev-haskell/regex-compat
+ dev-haskell/utf8-string
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"