summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/sun-jaf-bin/sun-jaf-bin-1.1.ebuild')
-rw-r--r--dev-java/sun-jaf-bin/sun-jaf-bin-1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-java/sun-jaf-bin/sun-jaf-bin-1.1.ebuild b/dev-java/sun-jaf-bin/sun-jaf-bin-1.1.ebuild
new file mode 100644
index 000000000000..42c5c2b9521f
--- /dev/null
+++ b/dev-java/sun-jaf-bin/sun-jaf-bin-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jaf-bin/sun-jaf-bin-1.1.ebuild,v 1.1 2006/08/02 22:53:45 nelchael Exp $
+
+inherit java-pkg-2
+
+At="jaf-1_1-fr.zip"
+DESCRIPTION="Sun's JavaBeans Activation Framework (JAF)"
+SRC_URI="${At}"
+HOMEPAGE="http://java.sun.com/products/javabeans/glasgow/jaf.html"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~ppc64"
+LICENSE="sun-bcla-jaf"
+SLOT="0"
+DEPEND=">=app-arch/unzip-5.50-r1"
+RDEPEND=">=virtual/jre-1.4"
+IUSE="doc"
+RESTRICT="fetch"
+S=${WORKDIR}/jaf-${PV}
+
+pkg_nofetch() {
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${HOMEPAGE}"
+ einfo " 2. Download ${At}"
+ einfo " 3. Move file to ${DISTDIR}"
+ einfo
+}
+
+src_compile() { :; }
+
+src_install() {
+ dodoc RELNOTES.txt README.txt LICENSE.txt
+ use doc && java-pkg_dohtml -r docs/
+ java-pkg_dojar activation.jar
+}
+