summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/velocity/velocity-1.3.ebuild')
-rw-r--r--dev-java/velocity/velocity-1.3.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-java/velocity/velocity-1.3.ebuild b/dev-java/velocity/velocity-1.3.ebuild
index f64607f837fc..b0bee60ffefb 100644
--- a/dev-java/velocity/velocity-1.3.ebuild
+++ b/dev-java/velocity/velocity-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.3.ebuild,v 1.6 2004/03/19 01:07:41 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.3.ebuild,v 1.7 2004/06/03 02:24:55 agriffis Exp $
DESCRIPTION="A Java-based template engine that allows easy creation/rendering of documents that format and present data."
HOMEPAGE="http://jakarta.apache.org/velocity/"
@@ -22,25 +22,25 @@ RDEPEND=">=dev-java/sun-jdk-1.3.1
src_compile () {
cd ${S}/build
local myc
- if [ -n "`use jikes`" ] ; then
+ if use jikes ; then
myc="${myc} -Dbuild.compiler=jikes"
fi
- if [ -n "`use j2ee`" ] ; then
+ if use j2ee ; then
cp /opt/sun-j2ee-1.3.1/lib/j2ee.jar ${S}/build/lib
ANT_OPTS=${myc} ant jar-J2EE || die "Java compile failed."
else
ANT_OPTS=${myc} ant jar || die "Java compile failed"
fi
- if [ -n "`use doc`" ] ; then
+ if use doc ; then
ant javadocs || die "Document compile failed"
fi
}
src_install () {
cd ${S}
- if [ -n "`use j2ee`" ] ; then
+ if use j2ee ; then
dojar bin/${PN}-J2EE-${PV}.jar
else
dojar bin/${PN}-${PV}.jar