summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc/files')
-rw-r--r--dev-lang/ghc/files/ghc-6.12.1-configure-CHOST.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lang/ghc/files/ghc-6.12.1-configure-CHOST.patch b/dev-lang/ghc/files/ghc-6.12.1-configure-CHOST.patch
new file mode 100644
index 000000000000..cbb288cc06c2
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-6.12.1-configure-CHOST.patch
@@ -0,0 +1,29 @@
+--- old-ghc-6.12.0.20091010/configure.ac 2009-11-07 14:11:31.747192438 +0100
++++ new-ghc-6.12.0.20091010/configure.ac 2009-11-07 14:11:31.752194402 +0100
+@@ -219,6 +219,8 @@
+ exit 1
+ fi
+ fi
++build=`echo "$build" | sed -e 's/linux-gnu/linux/' -e 's/-pc-/-unknown-/'`
++build=`echo "$build" | sed -e 's/i686/i386/'`
+
+ if test "$host" = ""
+ then
+@@ -231,6 +233,8 @@
+ exit 1
+ fi
+ fi
++host=`echo "$host" | sed -e 's/linux-gnu/linux/' -e 's/-pc-/-unknown-/'`
++host=`echo "$host" | sed -e 's/i686/i386/'`
+
+ if test "$target" = ""
+ then
+@@ -243,6 +247,8 @@
+ exit 1
+ fi
+ fi
++target=`echo "$target" | sed -e 's/linux-gnu/linux/' -e 's/-pc-/-unknown-/'`
++target=`echo "$target" | sed -e 's/i686/i386/'`
+
+ exeext=''
+ soext='.so'