summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc/ghc-6.2-r1.ebuild')
-rw-r--r--dev-lang/ghc/ghc-6.2-r1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-lang/ghc/ghc-6.2-r1.ebuild b/dev-lang/ghc/ghc-6.2-r1.ebuild
index 44e43e11bba7..b5f323e93dcd 100644
--- a/dev-lang/ghc/ghc-6.2-r1.ebuild
+++ b/dev-lang/ghc/ghc-6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2-r1.ebuild,v 1.2 2004/03/31 09:38:36 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2-r1.ebuild,v 1.3 2004/05/12 11:07:44 pappy Exp $
#Some explanation of bootstrap logic:
#
@@ -75,7 +75,7 @@ src_unpack() {
patch -p0 < ${FILESDIR}/ghc-6.2.documentation.patch
# hardened-gcc needs to be disabled, because the
# mangler doesn't accept its output
- bzcat ${FILESDIR}/ghc-6.2.hardened-gcc.patch.bz2 | patch -p0
+ bzcat ${FILESDIR}/ghc-6.2.hardened.patch.bz2 | patch -p0
}
src_compile() {
@@ -89,11 +89,9 @@ src_compile() {
# (this is still necessary, even though we have the patch, because
# we might be bootstrapping from a version that didn't have the
# patch included)
- if has_version "sys-devel/hardened-gcc"
- then
- echo "SRC_CC_OPTS+=-yet_exec -yno_propolice" >> mk/build.mk
- echo "SRC_HC_OPTS+=-optc-yet_exec -optc-yno_propolice" >> mk/build.mk
- fi
+ # new hardened gcc switches by pappy
+ echo "SRC_CC_OPTS+=-fno-pic -fno-stack-protector" >> mk/build.mk
+ echo "SRC_HC_OPTS+=-optc-fno-pic -optc-fno-stack-protector" >> mk/build.mk
# force the config variable ArSupportsInput to be unset;
# ar in binutils >= 2.14.90.0.8-r1 seems to be classified