summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mosml/mosml-2.01-r1.ebuild')
-rw-r--r--dev-lang/mosml/mosml-2.01-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-lang/mosml/mosml-2.01-r1.ebuild b/dev-lang/mosml/mosml-2.01-r1.ebuild
index ecfb66ed4646..f065eaefa9ea 100644
--- a/dev-lang/mosml/mosml-2.01-r1.ebuild
+++ b/dev-lang/mosml/mosml-2.01-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01-r1.ebuild,v 1.1 2008/06/06 01:26:53 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01-r1.ebuild,v 1.2 2009/05/30 02:11:23 darkside Exp $
inherit eutils
@@ -18,6 +18,10 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-malloc.patch" #154859
+
+ #Fixing pre-stripped files
+ sed -i -e "/STRIP/d" mosmlyac/Makefile || die "sed Makefile failed"
+ sed -i -e "/STRIP/d" runtime/Makefile || die "sed Makefile failed"
}
src_compile() {