summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.1.2-r3.ebuild')
-rw-r--r--dev-lang/python/python-3.1.2-r3.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/dev-lang/python/python-3.1.2-r3.ebuild b/dev-lang/python/python-3.1.2-r3.ebuild
index 0ff22b475bb0..7e220966ade8 100644
--- a/dev-lang/python/python-3.1.2-r3.ebuild
+++ b/dev-lang/python/python-3.1.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.2 2010/05/01 22:25:51 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.3 2010/05/02 16:39:55 arfrever Exp $
EAPI="3"
@@ -165,10 +165,6 @@ src_configure() {
--with-system-ffi
}
-src_compile() {
- emake EXTRA_CFLAGS="${CFLAGS}" || die "emake failed"
-}
-
src_test() {
# Tests will not work when cross compiling.
if tc-is-cross-compiler; then
@@ -204,7 +200,7 @@ src_test() {
done
elog "If you would like to run them, you may:"
- elog "cd ${EPREFIX}$(python_get_libdir)/test"
+ elog "cd '${EPREFIX}$(python_get_libdir)/test'"
elog "and run the tests separately."
python_disable_pyc
@@ -233,13 +229,15 @@ src_install() {
prep_ml_includes $(python_get_includedir)
+ dodoc Misc/{ACKS,HISTORY,NEWS} || die "dodoc failed"
+
if use examples; then
insinto /usr/share/doc/${PF}/examples
doins -r "${S}/Tools" || die "doins failed"
fi
- newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT}
- newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT}
+ newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT} || die "newinitd failed"
+ newconfd "${FILESDIR}/pydoc.conf" pydoc-${SLOT} || die "newconfd failed"
}
pkg_preinst() {
@@ -272,7 +270,6 @@ pkg_postinst() {
ewarn "It is recommended to currently have Python wrapper configured to use Python 2."
ewarn "Having Python wrapper configured to use Python 3 is unsupported."
ewarn
- ebeep 6
fi
if [[ "${python_updater_warning}" == "1" ]]; then
@@ -284,7 +281,12 @@ pkg_postinst() {
ewarn
ewarn "\e[1;31m************************************************************************\e[0m"
ewarn
- ebeep 12
+
+ local n
+ for ((n = 0; n < 12; n++)); do
+ echo -ne "\a"
+ sleep 1
+ done
fi
}