summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dbus-glib/dbus-glib-0.78.ebuild')
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.78.ebuild25
1 files changed, 9 insertions, 16 deletions
diff --git a/dev-libs/dbus-glib/dbus-glib-0.78.ebuild b/dev-libs/dbus-glib/dbus-glib-0.78.ebuild
index 709ecb50f0ef..5647595ab790 100644
--- a/dev-libs/dbus-glib/dbus-glib-0.78.ebuild
+++ b/dev-libs/dbus-glib/dbus-glib-0.78.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.78.ebuild,v 1.3 2008/12/30 19:18:01 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.78.ebuild,v 1.4 2009/01/18 20:34:47 eva Exp $
inherit eutils multilib autotools bash-completion
@@ -11,15 +11,18 @@ SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="|| ( GPL-2 AFL-2.1 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="bash-completion debug doc selinux test"
+IUSE="bash-completion debug doc test"
RDEPEND=">=sys-apps/dbus-1.1.0
>=dev-libs/glib-2.10
- selinux? ( sys-libs/libselinux )
>=dev-libs/expat-1.95.8"
DEPEND="${RDEPEND}
dev-util/pkgconfig
- doc? ( app-doc/doxygen app-text/xmlto )
+ sys-devel/gettext
+ doc? (
+ app-doc/doxygen
+ app-text/xmlto
+ >=dev-util/gtk-doc-1.4 )
dev-util/gtk-doc-am"
BASH_COMPLETION_NAME="dbus"
@@ -40,24 +43,14 @@ src_unpack() {
src_compile() {
econf \
$(use_enable bash-completion) \
- $(use_enable selinux) \
$(use_enable debug verbose-mode) \
$(use_enable debug checks) \
$(use_enable debug asserts) \
$(use_enable test tests) \
$(use_with test test-socket-dir "${T}"/dbus-test-socket) \
- --with-system-pid-file=/var/run/dbus.pid \
- --with-system-socket=/var/run/dbus/system_bus_socket \
- --with-session-socket-dir=/tmp \
- --with-dbus-user=messagebus \
--localstatedir=/var \
$(use_enable doc doxygen-docs) \
- --disable-xml-docs \
- || die "econf failed"
-
- # after the compile, it uses a selinuxfs interface to
- # check if the SELinux policy has the right support
- use selinux && addwrite /selinux/access
+ $(use_enable doc gtk-doc)
emake || die "make failed"
}