summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libaio/libaio-0.3.106-r1.ebuild')
-rw-r--r--dev-libs/libaio/libaio-0.3.106-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libaio/libaio-0.3.106-r1.ebuild b/dev-libs/libaio/libaio-0.3.106-r1.ebuild
new file mode 100644
index 000000000000..e86f7a881a89
--- /dev/null
+++ b/dev-libs/libaio/libaio-0.3.106-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/libaio-0.3.106-r1.ebuild,v 1.1 2006/05/17 13:54:02 chutzpah Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Asynchronous input/output library that uses the kernels native interface"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/andrea/libaio/"
+# Rip out of src rpm that Redhat uses:
+# http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.3.104-build.patch
+}
+
+src_install() {
+ make prefix="${D}/usr" libdir="${D}/usr/$(get_libdir)" install || die
+ doman man/*
+ dodoc ChangeLog TODO
+
+ # remove stuff provided by man-pages now
+ rm "${D}"/usr/share/man/man3/aio_{cancel,error,fsync,read,return,suspend,write}.*
+}